Centos 8 Dual nic Nwtwork speed issue

Issues related to configuring your network
Post Reply
vkkindia
Posts: 3
Joined: 2020/06/30 18:14:23

Centos 8 Dual nic Nwtwork speed issue

Post by vkkindia » 2020/06/30 18:33:23

Hi,
I recently upgraded from Centos7 to Centos8, the system is having two NIC.
In the nic using 8139too, the network speed is drastically slow. It start with 500 KiB/s and the speed gradually reduces, reduces .. until it reaches 100KiB/s within 1 min, and still reducing... So eventually unusable for downloads.
When download is interrupted and continued, again it start from 500 KiB and comes down to 100KiB.

The same system with centos7 has no issues.

It behaves something like speed cap is put.
Any suggestion, how to solve or debug.

User avatar
TrevorH
Forum Moderator
Posts: 28831
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Centos 8 Dual nic Nwtwork speed issue

Post by TrevorH » 2020/06/30 19:53:18

I'd suggest experimenting with ethtool to turn off the various "offload" optimizations on the ethernet card and see if one of those helps.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

vkkindia
Posts: 3
Joined: 2020/06/30 18:14:23

Re: Centos 8 Dual nic Nwtwork speed issue

Post by vkkindia » 2020/07/01 14:34:40

I already did that thats why I am atleast getting 100KiB/s or else it was 10 Kb

Code: Select all

ethtool -K enp1s2   gso off gro off

ethtool enp1s2
Settings for enp1s2:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  Not reported
	Advertised pause frame use: No
	Advertised auto-negotiation: No
	Advertised FEC modes: Not reported
	Speed: 100Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 32
	Transceiver: internal
	Auto-negotiation: off
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: yes



TrevorH wrote:
2020/06/30 19:53:18
I'd suggest experimenting with ethtool to turn off the various "offload" optimizations on the ethernet card and see if one of those helps.

vkkindia
Posts: 3
Joined: 2020/06/30 18:14:23

Re: Centos 8 Dual nic Nwtwork speed issue

Post by vkkindia » 2020/07/01 15:42:00

After various try found the solution

mii-tool -R NIC_INTERFACE #-R, --reset reset MII to poweron state

it hooked to

enp1s2: 10 Mbit, half duplex, link ok

But even though half duplex I am getting speed of 400KB/s instead of full bandwidth of 1 MB/s. Will look into this later

It might be useful for people who got struck at this issue.

User avatar
TrevorH
Forum Moderator
Posts: 28831
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Centos 8 Dual nic Nwtwork speed issue

Post by TrevorH » 2020/07/01 15:46:50

I'd just say this is a 10/100Mbps card and it was first made over 20 years ago. Perhaps time to invest in something a little better!
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 8 - Networking Support”