Centos 8 as a hotspot : WPA-PSK keep saying wrong password

Issues related to configuring your network
Post Reply
netclic
Posts: 2
Joined: 2020/03/29 09:51:17

Centos 8 as a hotspot : WPA-PSK keep saying wrong password

Post by netclic » 2020/04/05 17:53:03

Hi,

I'm trying to setup a wifi hotspot on centos 8.

I've setup the wlan0 device as member of a bridge with an ethernet interface.
If I configure the hotspot to be in WEP mode, everything is fine : my android phone connects to it, get an ip from my dsl modem and I can surf the net.

But if i activate those settings below (wpa-psk mode), my android keep saying "wrong password" (tried on 2 android phone) and the connection is never established even if the password is correct, I tried with a very simple password of 8 char.

Here are my parameters :

Code: Select all

802-11-wireless.ssid:                   MY_AP
802-11-wireless.mode:                   ap
802-11-wireless.band:                   bg
802-11-wireless.channel:                3
802-11-wireless.bssid:                  --
802-11-wireless.rate:                   0
802-11-wireless.tx-power:               0
802-11-wireless.mac-address:            --
802-11-wireless.cloned-mac-address:     --
802-11-wireless.generate-mac-address-mask:--
802-11-wireless.mac-address-blacklist:  --
802-11-wireless.mac-address-randomization:default
802-11-wireless.mtu:                    auto
802-11-wireless.seen-bssids:            3C:33:00:F6:6D:89,86:06:24:AA:66:2A,D2:5A:5F:59:37:C9
802-11-wireless.hidden:                 non
802-11-wireless.powersave:              0 (default)
802-11-wireless.wake-on-wlan:           0x1 (default)
802-11-wireless-security.key-mgmt:      wpa-psk
802-11-wireless-security.wep-tx-keyidx: 0
802-11-wireless-security.auth-alg:      --
802-11-wireless-security.proto:         --
802-11-wireless-security.pairwise:      --
802-11-wireless-security.group:         --
802-11-wireless-security.pmf:           1 (disable)
802-11-wireless-security.leap-username: --
802-11-wireless-security.wep-key0:      <hidden>
802-11-wireless-security.wep-key1:      <hidden>
802-11-wireless-security.wep-key2:      <hidden>
802-11-wireless-security.wep-key3:      <hidden>
802-11-wireless-security.wep-key-flags: 0 (aucun)
802-11-wireless-security.wep-key-type:  unknown
802-11-wireless-security.psk:           <hidden>
802-11-wireless-security.psk-flags:     0 (aucun)
802-11-wireless-security.leap-password: <hidden>
802-11-wireless-security.leap-password-flags:0 (aucun)
802-11-wireless-security.wps-method:    0x0 (default)
802-11-wireless-security.fils:          0 (default)
I see that the password is correctly stored in a keys-<ifname> in /etc/sysconfig/network-scripts.
I tried to setup an entry in /etc/wpa_supplicant/wpa_supplicant.conf too and tried several configuration of 802-11-wireless-security without success.

someone's got an idea on what's wrong ?
Franck

Post Reply

Return to “CentOS 8 - Networking Support”