Emulex on HP Blade

Issues related to configuring your network
Post Reply
geneb
Posts: 3
Joined: 2019/12/10 20:43:44

Emulex on HP Blade

Post by geneb » 2019/12/10 20:48:54

I can't get CentOS 8 to recognise the network interfaces on an BL460 G8 blade. CentOS 7 does fine.

lspci shows the same for both 7 and 8.
04:00.0 Ethernet controller: Emulex Corporation OneConnect 10Gb NIC (be3) (rev 01)
04:00.1 Ethernet controller: Emulex Corporation OneConnect 10Gb NIC (be3) (rev 01)

Anyone know how to get CentOS 8 to recognise the interfaces?

User avatar
toracat
Forum Moderator
Posts: 7411
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Emulex on HP Blade

Post by toracat » 2019/12/11 00:21:20

Please post the output from:
lspci -nn | grep -i net
CentOS Forum FAQ

geneb
Posts: 3
Joined: 2019/12/10 20:43:44

Re: Emulex on HP Blade

Post by geneb » 2019/12/11 16:28:35

# lspci -nn | grep -i net
04:00.0 Ethernet controller [0200]: Emulex Corporation OneConnect 10Gb NIC (be3) [19a2:0710] (rev 01)
04:00.1 Ethernet controller [0200]: Emulex Corporation OneConnect 10Gb NIC (be3) [19a2:0710] (rev 01)

User avatar
toracat
Forum Moderator
Posts: 7411
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Emulex on HP Blade

Post by toracat » 2019/12/11 17:06:35

The CentOS-8 kernel does not support your device [19a2:0710]. However ELRepo's kmod-be2net should work for you.
sudo dnf install elrepo-release
sudo dnf install kmod-be2net
CentOS Forum FAQ

geneb
Posts: 3
Joined: 2019/12/10 20:43:44

Re: Emulex on HP Blade

Post by geneb » 2019/12/12 19:03:18

toracat wrote:
2019/12/11 17:06:35
The CentOS-8 kernel does not support your device [19a2:0710]. However ELRepo's kmod-be2net should work for you.
sudo dnf install elrepo-release
sudo dnf install kmod-be2net
That did the trick. I had to use a usb dongle to get the files installed. I realy hope new versions will work better as this has made installing a blade a little more problematic.

Thanks.

Post Reply

Return to “CentOS 8 - Networking Support”