BCM4352 Cannot compile driver...

Issues related to configuring your network
Post Reply
Posts: 2
Joined: 2019/11/11 09:19:02

BCM4352 Cannot compile driver...

Post by alain0336 » 2019/11/11 09:34:32

Can someone explain steps to set up wifi with broadcom chip...?
I downloaded "hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz"

[root@localhost alain]# mkdir /usr/local/src/hybrid-wl
[root@localhost alain]# cd /usr/local/src/hybrid-wl/
[root@localhost hybrid-wl]# tar xvzf /home/alain/Downloads/hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz

[root@localhost hybrid-wl]# yum install kernel-devel kernel-headers
Last metadata expiration check: 0:25:56 ago on Mon 11 Nov 2019 08:52:14 AM MST.
Package kernel-devel-4.18.0-80.11.2.el8_0.x86_64 is already installed.
Package kernel-headers-4.18.0-80.11.2.el8_0.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
[root@localhost hybrid-wl]# make -C /lib/modules/`uname -r`/build/ M=`pwd`
make: *** /lib/modules/4.18.0-80.el8.x86_64/build/: No such file or directory. Stop.

Posts: 509
Joined: 2012/06/26 14:20:47

Re: BCM4352 Cannot compile driver...

Post by stevemowbray » 2019/11/11 11:38:19

Reboot so you're using the kernel that matches your headers and devel packages.

Posts: 181
Joined: 2017/04/22 08:11:04

Re: BCM4352 Cannot compile driver...

Post by bonedome » 2019/11/11 19:00:59

I also have broadcom wireless, the easiest way to get it working is install the akmod-wl and broadcom-wl rpms (and as mentioned kernel-devel) from rpmfusion, https://download1.rpmfusion.org/nonfree ... index.html
Once installed enable akmods service

Code: Select all

systemctl enable akmods.service
Then reboot, the boot process will take a couple of minutes longer than usual while the wireless module is built and installed.

Code: Select all

systemctl status akmods.service -l
should show that the wl module is installed.
I then disable akmods service to stop the module being built every boot.

Code: Select all

systemctl disable akmods.service
When a new kernel is installed enable akmods service, reboot to new kernel and wl module is automatically rebuilt for new kernel.

Posts: 2
Joined: 2019/11/11 09:19:02

[SOLVED]Re: BCM4352 Cannot compile driver...

Post by alain0336 » 2019/11/16 07:14:01

So i solved my wifi problem in a very simple way and was curious if someone could tell me if there is something else to do or something i ahve missed... I read page after page of elrepo this and that, Broadcom how to, ndiswrapper, and nothing was working at all, dependency after dependency, wrong header, no key, permission denied, blah blah blah....

I literally put four packages in a folder called wifi under my home directory and executed

Code: Select all

rpm -ivh *.rpm
I did a reboot and i have wifi!

WHY the fsck did this work and why is there no tutorial with literally a TWO STEP FIX.... Everything i read was so involved and complicated!!!

Please enlighten me so i can stay humble.
wifi.png (136.18 KiB) Viewed 870 times

Post Reply

Return to “CentOS 8 - Networking Support”