Centos 8 and broadcom ?

Issues related to configuring your network
Post Reply
Posts: 1
Joined: 2019/09/27 11:37:31

Centos 8 and broadcom ?

Post by larigan » 2019/09/27 11:39:42

I have broadcom chip for wireless. -> BCM43142

How to install drivers to get network?

Posts: 161
Joined: 2017/04/22 08:11:04

Re: Centos 8 and broadcom ?

Post by bonedome » 2019/10/04 19:21:05

your question answered mine, one of the reasons I'll wait a while to install CentOS 8
I have BCM 4313, using the rpmfusion wl packages.
The RPMFusion el8 repo doesn't contain the broadcom akmod/kmod wl rpms yet, but you could try installing the el7 rpms from here https://download1.rpmfusion.org/nonfree ... index.html you'll need the broadcom-wl, akmod-wl and (current/running/uname -r) kernel-devel packages, they work with the latest elrepo mainline kernel (currently 5.3.2-1.el7.elrepo.x86_64) so I can't see the kernel version being a problem.
The broadcom-wl and akmod-wl rpms will need to be installed together then a reboot.
I know it's never a great idea to install rpms from different releases, but this sounds like you have a fresh install with no working wireless, so why not be the test pilot ;)
Hopefully rpmfusion will have el8 rpms soon.
Let us know if you have success.

Posts: 1
Joined: 2020/06/02 11:50:26

Re: Centos 8 and broadcom ?

Post by eyeprotocol » 2020/06/02 12:02:10

Hello. I am new to Centos. Since i am faced with the same problem, i was wondering if someone would point me to a proper set of instructions on resolving this. It appears that the "repo" mentioned, now has packages for version 8, but i need further guidance if available.

User avatar
Posts: 31
Joined: 2020/05/29 15:01:00

Re: Centos 8 and broadcom ? - SOLVED (for me)

Post by oceanjeremy » 2020/06/06 13:51:08

I just installed CentOS 8 on a MacBook Pro and it wasn't recognizing my Wi-Fi or my ethernet controller. No internet at all. This got me connected in about fifteen minutes.

I got my instructions from these two pages:
- https://centos.pkgs.org/8/rpmfusion-non ... h.rpm.html
- https://centos.pkgs.org/8/rpmfusion-non ... 4.rpm.html

This is what worked for me:
  1. Get on a different machine (one that connects to the internet), so I can put the Wi-Fi driver on a USB drive and take it to my new CentOS machine
  2. Download Broadcom driver common files: https://download1.rpmfusion.org/nonfree ... noarch.rpm
  3. Download wl kernel modules: https://download1.rpmfusion.org/nonfre ... x86_64.rpm
  4. Take those (via USB drive) over to my new CentOS machine and drop into terminal (as root user)
  5. Run this command:

    Code: Select all

    # rpm -Uvh broadcom-wl- kmod-wl-4.18.0-147.el8.x86_64-
    # dnf install kmod-wl-4.18.0-147.el8.x86_64 broadcom-wl
  6. Reboot CentOS 8 machine
To be completely honest I did this last night while a little bit tipsy and I can't remember each step exactly. I think you might need to double check your kernel (# uname -r) and make sure it matches? Not sure, I'm a Linux beginner myself.

But hopefully this can get you up and running!
Please be kind! I've only been a Linux user for two months.

Post Reply

Return to “CentOS 8 - Networking Support”