new Nic adapater not showing any IPaddress

Issues related to configuring your network
Post Reply
greenf9x08
Posts: 3
Joined: 2023/11/02 11:06:40

new Nic adapater not showing any IPaddress

Post by greenf9x08 » 2023/11/02 11:35:23

Hello,
i have virtual box latest version with Cento OS stream vs 9 on it
there is a old Nic with its Ip address (Bridged adapter network type)
i created a new Nic, same config, bridge adapter with dual wireless. enabled, of course.
i restarted, but the new adapter dont show any ip address is there a specific reason or should i edit the system connections in network manager or
in sysconfig network scripts should i add an new script for that nic with a static Ip address?
This what ifconfig shows after the setup of the new NIC and after restarting of the OS
Attachments
Screenshot 2023-11-02 105829.png
Screenshot 2023-11-02 105829.png (197.54 KiB) Viewed 17735 times

User avatar
jlehtone
Posts: 4553
Joined: 2007/12/11 08:17:33
Location: Finland

Re: new Nic adapater not showing any IPaddress

Post by jlehtone » 2023/11/02 20:23:27

First, the 'ipconfig' got a competitor with more features, 'ip', over two decades ago.
Even the 'ip' is now mainly for checking state, e.g. ip li, ip ad, and ip ro.

The default for setting up and managing network configuration is NetworkManager.service.
With it one can get the summary information:

Code: Select all

nmcli
nmcli d s
nmcli c s
On default setup the NetworkManager (NM) will automatically generate a connection for each interface
and the connection will use DHCP to get config.

If you have not prevented that, then NM does not receive config from DHCP, i.e. from virtualbox or beyond.

Post Reply