Ports opened for SMTP (587 / 465), still cannot connect

Issues related to configuring your network
Post Reply
MBVape64
Posts: 1
Joined: 2021/06/18 23:51:34

Ports opened for SMTP (587 / 465), still cannot connect

Post by MBVape64 » 2021/06/18 23:55:11

Hello,

My server hosts a site that has to connect on smtp to an outside mail server (Either 587 or 465).

I set up the ports in firewalld:

Code: Select all

[root@60b250e9c256a30001258cd5 public]# firewall-cmd --zone=public --permanent --list-ports
10090-10100/tcp 587/tcp 465/tcp

But I still cannot connect to the outside mail server.

According to https://portchecker.co/ both ports are closed

When I try to telnet to them from my own PC, the connection fails.

According to the e-mail provider, the issue is on my side....

Any ideas what this can be?

User avatar
TrevorH
Forum Moderator
Posts: 30874
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Ports opened for SMTP (587 / 465), still cannot connect

Post by TrevorH » 2021/06/19 00:24:20

You don't need to (and should not) open ports in firewalld to allow outbound connections to other servers. Those are allowed by default and aren't done that way. If you cannot connect to the server on those ports from your own machine then it implies that either the site in question isn't listening on those ports or yourr ip is blocked.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 8 - Networking Support”