AMD Radeon HD 8750M not working on Centos 9 Stream

Issues related to hardware problems
Post Reply
Posts: 4
Joined: 2014/09/24 19:51:44

AMD Radeon HD 8750M not working on Centos 9 Stream

Post by asmodeus410 » 2022/04/17 14:11:09

I made a fresh install of centos 9 stream on my laptop (my laptop is an experienced one from 2013 or maybe 2014), an Acer aspire v5552G with AMD A10 processor (8gb ram) and a gpu AMD Radeon HD 8750M with 2Gb of independent RAM.
I believe that I still should be able to use this laptop and wanted to install centos 9 stream. Obviously with microsoft this computer is dead.
My idea is to run ms windows 10 on a VM within the Centos 9 stream
So after creating the usb and installing centos 9 stream, the graphics just dont work. When I booted I just see vertical lines (white and kind of gray )

I tried to download the drivers from amd webpage and no way either. looks like X server is old for the drivers and too new for the OS ??
Somebody can help providing a procedure and/or appropriate driver ?
How come if the installation worked with graphics, once done and rebooted it just crashes ?
Help would be pretty much appreciated
NOTE: With centos 8 stream the same laptop with the same GPU works like a charm

Post Reply