SD card not detected in 5.4 kernel

Issues related to hardware problems
Post Reply
koxakis
Posts: 3
Joined: 2021/01/02 22:35:04

SD card not detected in 5.4 kernel

Post by koxakis » 2021/01/02 23:13:59

Hello and good year to all!

I am losing SD card reader functionality when I am booting a 5.x kernel installed from elrepo, The question is how to get it working again. Am I missing a step from the kernel installation or this is normal with elrepo kernels?

This is the guide I used https://computingforgeeks.com/how-to-in ... tos-linux/

My OS is Centos stream ( Lenovo ThinkPad L560 i5 ). Booting the kernel that came with the installation ( 4.18 ) SD card is detected normally.
I Installed the ELrepo repository and installed both kernel-lt and ml ( 5.4 with all available packets involving the kernel and 5.10 ) but none of them detect the SD card neither produce any dmesg reporting.
lspci output

Code: Select all

05:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)
lshw output

Code: Select all

         *-pci:1                                                                 
373              description: PCI bridge                                            
374              product: Sunrise Point-LP PCI Express Root Port #5                 
375              vendor: Intel Corporation                                          
376              physical id: 1c.4                                                  
377              bus info: pci@0000:00:1c.4                                         
378              version: f1                                                        
379              width: 32 bits                                                     
380              clock: 33MHz                                                       
381              capabilities: pci pciexpress msi pm normal_decode bus_master cap_list
382              configuration: driver=pcieport                                     
383              resources: irq:123 memory:e2400000-e24fffff                        
384            *-generic UNCLAIMED                                                  
385                 description: SD Host controller                                 
386                 product: SD/MMC Card Reader Controller                          
387                 vendor: O2 Micro, Inc.                                          
388                 physical id: 0                                                  
389                 bus info: pci@0000:05:00.0                                      
390                 version: 01                                                     
391                 width: 32 bits                                                  
392                 clock: 33MHz                                                    
393                 capabilities: pm msi pciexpress bus_master cap_list             
394                 configuration: latency=0                                        
395                 resources: memory:e2401000-e2401fff memory:e2400000-e24007ff
Another noteworthy thing is that sdhci seems to not be loaded.
I got this output

Code: Select all

rmmod: ERROR: Module sdhci_pci is not currently loaded
rmmod: ERROR: Module sdhci_acpi is not currently loaded
rmmod: ERROR: Module sdhci is not currently loaded
by following the steps of this post https://askubuntu.com/questions/824804/ ... -16-04-lts

Code: Select all

sudo rmmod sdhci_pci sdhci_acpi sdhci
sudo modprobe sdhci debug_quirks2="0x10000"
sudo modprobe sdhci_pci
I haven't found anything else relating to the problem, I tried reinstalling udisks2 as some posts suggested but to no avail.

Thanks in advance !!

Edit: changed code to link tags for link
Last edited by koxakis on 2021/01/04 09:02:40, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 30173
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: SD card not detected in 5.4 kernel

Post by TrevorH » 2021/01/03 13:07:37

Run lspci -nn | grep O2 and then use the two hex identifiers that shows you like [vvvv:dddd] to look up the PCI vendor/device ids to see what kernel module supports that device like

Code: Select all

grep -i vvvv /lib/modules/$(uname -r)/modules.* | grep -i dddd


Do this first on the standard 4.18 kernel since that one works so you know it is supported there. Repeat on the ELRepo kernel and then you need to raise a bug report on ELRepo's bug tracker to get that module enabled in their el8 kernel .config file.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

koxakis
Posts: 3
Joined: 2021/01/02 22:35:04

Re: SD card not detected in 5.4 kernel

Post by koxakis » 2021/01/04 07:57:12

Thank you for the fast reply, I will raise a bug report!

I run the command and the output was this on the 4.18 kernel

Code: Select all

/lib/modules/4.18.0-259.el8.x86_64/modules.alias:alias pci:v00001217d00008621sv*sd*bc*sc*i* sdhci_pci
Booting the 5.4 elrepo kernel I get no output from grep.

koxakis
Posts: 3
Joined: 2021/01/02 22:35:04

Re: SD card not detected in 5.4 kernel

Post by koxakis » 2021/01/05 18:17:21

This is the bug report if anyone has a similar issue in the future, https://elrepo.org/bugs/view.php?id=1067

Thanks for the help and take care!

Post Reply

Return to “CentOS 8 - Hardware Support”