Stream and NVidia driver

Issues related to hardware problems
Post Reply
scottro
Forum Moderator
Posts: 2476
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Stream and NVidia driver

Post by scottro » 2020/12/20 00:00:37

On a machine with an NVidia card, I migrated to Stream, following the FAQ, and it kept working. However, I then did a fresh Stream install and neither Elrepo's nor rpmfusion's versions of NVidia drivers worked. (For this particular machine, Nouveau wasn't satisfactory--I don't game on it, but it just gave bad resolution.)

I've communicated with Elrepo, and they are aware of it, I suspect rpmfusion is as well. Right now, CentOS Nvidia drivers are looking for older kernels than are used by Stream.

I didn't work very hard on a solution, just downloaded the drivers from NVidia's site. The errors made it obvious which dependencies I had to install, so I did so, and then it built. In hindsight, I should have installed dkms first, which I believe would make it unnecessary to rebuild NVidia when the kernel updates, but I only installed it after the fact.

Anyway, for those who have NVidia cards and use Stream, or do a fresh install of Stream, the drivers from NVidia's site are working.
New users should check the FAQ and Read Me First pages

lightman47
Posts: 1246
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Stream and NVidia driver

Post by lightman47 » 2020/12/20 14:14:27

Drats - I'd long forgotten about all the fun trying to keep things working after updates! I just changed two of my machines to Stream but fortunately they aren't ones I use daily. I have also installed a Ubuntu Desktop VM with which to experiment; looks like I'd better start learning.

As far as Nvidia - I've been removing it from my computers anyway. The performance increase was noticeable.

Thanks for the heads-up, though.
Remember - importing/building packages will likely "byte you in the butt" come update time, long after you'd forgotten you did that! Use repos whenever possible.

User avatar
jlehtone
Posts: 3270
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Stream and NVidia driver

Post by jlehtone » 2020/12/20 21:28:53

scottro wrote:
2020/12/20 00:00:37
I didn't work very hard on a solution, just downloaded the drivers from NVidia's site.
RPM's from their Yum-repo or the binary .run?

scottro
Forum Moderator
Posts: 2476
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: Stream and NVidia driver

Post by scottro » 2020/12/20 22:23:37

Sorry, I should have been clearer. I went to NVidia's site and downloaded from there.
New users should check the FAQ and Read Me First pages

User avatar
jlehtone
Posts: 3270
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Stream and NVidia driver

Post by jlehtone » 2020/12/20 22:55:57

By "repo" I did mean the http://developer.download.nvidia.com/co ... l8/x86_64/ that has CUDA (and driver).
NVidia's instructions are in https://docs.nvidia.com/datacenter/tesl ... kstart.pdf (also for CentOS Linux 8)
(No, I have not installed from there, not even for CentOS Linux, except the CUDA for CentOS 7.)

scottro
Forum Moderator
Posts: 2476
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: Stream and NVidia driver

Post by scottro » 2020/12/20 23:40:15

I went to their site where one goes to download drivers, https://www.nvidia.com/Download/index.aspx and got a driver for my GT710 card, choosing long lived. This downloads a script that runs the install. I didn't pay that much attention to it, to be honest, just watched for errors.
New users should check the FAQ and Read Me First pages

mprater
Posts: 22
Joined: 2020/04/16 19:10:33

Re: Stream and NVidia driver

Post by mprater » 2021/01/13 13:18:00

I'm using a kmod-nvidia from elrepo-testing on a CentOS 8 Linux machine: https://elrepo.org/bugs/view.php?id=1061

It contains the 455.45.01 nvidia driver. Works perfectly!

My question now is, how does/will this kmod work with CentOS 8 Stream?

User avatar
TrevorH
Forum Moderator
Posts: 30179
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Stream and NVidia driver

Post by TrevorH » 2021/01/13 14:15:41

It doesn't. Stream uses an unreleased upstream RHEL kernel and the KABI is not stable. ELRepo kmods will not work with it (or only in the brief period where the Stream kernel matches the current RHEL point release one).
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

mprater
Posts: 22
Joined: 2020/04/16 19:10:33

Re: Stream and NVidia driver

Post by mprater » 2021/01/13 15:20:31

Right, thanks Trevor. That's what I suspected, but wanted confirmation.

These sorts of issues seem to be intentionally 'overlooked' by the proponents of CentOS Stream.

Post Reply

Return to “CentOS 8 - Hardware Support”