CentOS 8 does not boot with Radeon RX 480 as primary GPU

Issues related to hardware problems
Post Reply
rob153
Posts: 10
Joined: 2020/05/17 13:52:00

CentOS 8 does not boot with Radeon RX 480 as primary GPU

Post by rob153 » 2020/10/24 17:37:40

Hi,

I'm trying to replace my current primary graphics card and install an RX 480, but when doing so CentOS 8 no longer boots. The boot menu with the kernel selection appears, but after that I just get a blank screen and the boot hangs. Since I'm using an encrypted root partition and the blank screen occurs before I get prompted for the password, the scope of possible reasons is somewhat limited. I might mention that I have a second GPU installed, but since this did not change with the upgrade I don't expect it to be related.

Does anyone have suggestions as to how I should proceed with debugging this?

User avatar
TrevorH
Forum Moderator
Posts: 29902
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 8 does not boot with Radeon RX 480 as primary GPU

Post by TrevorH » 2020/10/24 17:52:14

Amend the current kernel parameters at the grub menu to append a space followed by the digit 3 to them and see if it will boot in command line only mode so you can read logs and work out why it happens and fix it.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

rob153
Posts: 10
Joined: 2020/05/17 13:52:00

Re: CentOS 8 does not boot with Radeon RX 480 as primary GPU

Post by rob153 » 2020/10/25 12:39:01

It does not boot to runlevel 3. The only thing I get is a blinking cursor and nothing more.

Also: given that it does not even proceed to the prompt for the root partition decryption password, doesn't that mean that the stage where this would matter is anyways never reached?

User avatar
TrevorH
Forum Moderator
Posts: 29902
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 8 does not boot with Radeon RX 480 as primary GPU

Post by TrevorH » 2020/10/25 13:09:44

Make sure you are booting without the keywords 'rhgb' and 'quiet' on the kernel command line so that you can see all kernel messages as they are issued. You can edit the arguments at the grub menu by pressing 'e' to edit , scroll down to the linux16 or linuxefi line and locate rggb quiet and delete them, then press ctrl-x to continue.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 8 - Hardware Support”