New CentOS 8 Install does not see SATA Drives

Issues related to hardware problems
Post Reply
silverjw
Posts: 7
Joined: 2019/07/16 14:44:25

New CentOS 8 Install does not see SATA Drives

Post by silverjw » 2020/10/23 02:23:45

Hello,

CentOS 8 does not “see” my SATA drives when I try to install.

First, let me say that CentOS 6 and 7 both see the drives without problem. so I presume this is a depreciation that occurred in CentOS 8 – But I can not find it in the list of products no longer supported in the Removed device drivers section of Red Hat hardware documentation for RHEL 8 (Section 11.1.1)

I had seen a post on the web from someone with a similar problem, and his resolution was the mpt3SAS patch from ElRepo...

So I have also gone through the list on ElRepo (http://elrepo.org/tiki/Packages) which admittedly warns it is a partial list, but found nothing relating to the MCP51.

Here are the particulars :

OLD Hardware : AMD Athlon X2 based system.
Southbridge: nVIDIA® nForce 430

LSPCI shows :

00:0e.0 IDE interface: NVIDIA Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: NVIDIA Corporation MCP51 Serial ATA Controller (rev a1)

I found another user here (Phil) that had a problem with drives and the MCP51 controller (from 2006), but the resolution did not appear in the post (!). This was not exactly the same problem, still, I wonder if the resolution would be relevant.

Any suggestions to resolve this problem, or as to where I could dig deeper would be appreciated.

TIA

-Jerry

User avatar
TrevorH
Forum Moderator
Posts: 29915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: New CentOS 8 Install does not see SATA Drives

Post by TrevorH » 2020/10/23 08:54:52

On CentOS 7 those controllers are supported by the sata_nv module which is not present in CentOS 8. You can see that by running grep -i 10de /lib/modules/$(uname -r)/modules.* | grep -i 0266 on both 7 and 8. ELRepo have a number of kmod-sata* packages for el8 but not that one. You could try asking them if they will build it via their bug tracker.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

silverjw
Posts: 7
Joined: 2019/07/16 14:44:25

Re: New CentOS 8 Install does not see SATA Drives

Post by silverjw » 2020/10/23 15:28:29

Thank you. I submitted the request this morning.

Best regards,

-J

silverjw
Posts: 7
Joined: 2019/07/16 14:44:25

Re: New CentOS 8 Install does not see SATA Drives

Post by silverjw » 2020/10/25 04:45:07

Hello,

I received a VERY quick response from the folks at ElRepo, where they asked for a little additional information… An LSPCI -nn, which I include here :

00:0e.0 IDE interface [0101]: NVIDIA Corporation MCP51 Serial ATA Controller
[10de:0266] (rev a1)
00:0f.0 IDE interface [0101]: NVIDIA Corporation MCP51 Serial ATA Controller
[10de:0267] (rev a1)

It SEEMS the key was the 10de:0266 and 10de:0267. These matched up with one of their existing kmods. From their letter :

>> Looking at our DeviceID page, it is supported by the sata_nv driver:

>> http://elrepo.org/tiki/DeviceIDs#sata_nv.ko

>> We have both the kmod-sata_nv package and its DUD image that is needed for the
>> installation, for EL8.

It wasn’t so easy to find the mod on the page referenced, but I entered the “dud” page from another package I knew of on their site, at

https://elrepo.org/linux/dud/el8/x86_64/

and found the

dd-sata_nv-3.5-1.el8_1.elrepo.iso

and

dd-sata_nv-3.5-2.el8_2.elrepo.iso

files there. Pick the one for the release you’re using.

If anyone else needs the kmods, that’s where they are.

After which, I spent many pleasant hours re-downloading el8 (now 8.2), and dd-ing to a USB drive (2.0). ;-)

So bottom line ? It WORKED !

Thanks for your help, Trevor, and thanks also to the nice folks at ElRepo !

Best regards !

-J

Post Reply

Return to “CentOS 8 - Hardware Support”