CENTOS 8 NVIDIA driver issue

Issues related to hardware problems
Post Reply
rxl561
Posts: 3
Joined: 2020/09/06 09:37:39

CENTOS 8 NVIDIA driver issue

Post by rxl561 » 2020/09/06 09:59:22

Hi, I have been using centos 7 for 2 years for scientific computing purposes and recently I switched to centos 8 but encountered issues not appreared on centos 7.

I have an old graphic card, quadro K2000, and my objective is to use the proprietary NVIDIA driver, as I use it on centos 7. Currently I am using xx driver, but the gnome desktop would randomly freeze using this driver (I don't know why) and I have to force restart which is too annoying, and I guess maybe a proprietary NVIDIA driver would help. However, each time when I want to install it, I got "oh no something has gone wrong" error on the login and have to uninstall that driver.

As a test, I am able to use the nvidia-detect program on centos 7, and get drivers properly installed, but I am not able to do that on centos 8. I checked this url:
viewtopic.php?f=55&t=74712&p=317157&hil ... ia#p317157
followed its instructions and used the code provided, still I got "oh no something has gone wrong" and have to uninstall the NVIDIA drivers.

My question is:

1. Why I cannot install the proprietary NVIDIA driver properly? Is it because this card is too old? How could I fix this issue.
2. Under the following instruction, I still get "oh no something has gone wrong", what could be the reasons?
- Installs Nvidia drivers ('kmod-nvidia' and 'nvidia-x11-drv') on CentOS
- Activates the selinux boolean domain_can_mmap_files
- Renames the bad xorg.conf provided by http://elrepo.org

Any help would be appreciated, please let me know if any further information is needed!

User avatar
toracat
Forum Moderator
Posts: 7451
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: CENTOS 8 NVIDIA driver issue

Post by toracat » 2020/09/07 04:17:43

Maybe you were hit by this bug?
CentOS Forum FAQ

rxl561
Posts: 3
Joined: 2020/09/06 09:37:39

Re: CENTOS 8 NVIDIA driver issue

Post by rxl561 » 2020/09/07 04:26:35

Possibly, now I switched back to centos 7, until this bug is fixed.

tunk
Posts: 794
Joined: 2017/02/22 15:08:17

Re: CENTOS 8 NVIDIA driver issue

Post by tunk » 2020/09/07 10:03:29

I'm sure you know that C8 uses Wayland as default (not Xorg)?

rxl561
Posts: 3
Joined: 2020/09/06 09:37:39

Re: CENTOS 8 NVIDIA driver issue

Post by rxl561 » 2020/09/07 12:20:05

I am not very familiar with this term but I uncommented

Code: Select all

WaylandEnable=false
in the file /etc/gdm3/custom.conf as suggested by some other solutions. What other operations do you suggest I could take for remediation?

Post Reply

Return to “CentOS 8 - Hardware Support”