Page 1 of 1

ELRepo broke my laptop keyboard (touchpad works, though, and so does USB keyboard)

Posted: 2020/06/23 18:31:25
by oceanjeremy
Background: I'm running CentOS 8 on a mid-2009 MacBook Pro.

I was having issues with the GUI desktop crashing, and saw that if you have an Nvidia graphics card it often helps the crashing issues to install an Nvidia graphics driver. So I got one from ELRepo and installed it.

As soon as it rebooted my laptop's keyboard stopped working. It works fine in the grub menu, but as soon as I select a kernel it goes dark. I couldn't get past the prompt for my LUKS password. I tried booting into recovery with the install ISO and uninstalling the ELRepo packages. Still didn't work.

So I ordered a USB keyboard off of Amazon. Once it arrived, I tried it out and — hooray! it worked.

However it turned out that the ELRepo installation also screwed with my NetworkManager so I had to manually add nameservers. Weird, but OK.

Still — I don't want to lug around a $5 USB keyboard (that will probably break within a year). I want my laptop's keyboard to still work past the grub menu!

Someone suggested I reinstall the kernel I was using so I tried that. I got this:

Code: Select all

[root@localhost ~]# yum reinstall kernel-4.18.0-147.8.1_el8_1.x86_64
Last metadata expiration check: 0:00:10 ago on Tue 23 Jun 2020 01:31:07 PM EDT.
Installed package kernel-4.18.0-147.8.1.el8_1.x86_64 (from BaseOS) not available.
Error: No packages marked for reinstall.
So I figure: What if I uninstall it and reinstall it?

Code: Select all

[root@localhost ~]# yum install kernel-4.18.0-147.8.1_el8_1.x86_64
Last metadata expiration check: 0:05:28 ago on Tue 23 Jun 2020 01:31:07 PM EDT.
No match for argument: kernel-4.18.0-147.8.1.el8_1.x86_64
Error: Unable to find a match: kernel-4.18.0-147.8.1.el8_1.x86_64
No dice. Looks like that kernel somehow disappeared from the repository.

So I thought, "What will happen if I upgrade to the new kernel?"

Upgrade worked as expected. It killed the connection to my Broadcom WiFi card, but I was expecting that (I was warned I'd need to repeat the driver install every time I upgrade kernel).

But... still no use of my laptop keyboard.

At this point I'm ready to back up my data and just wipe the machine and reinstall CentOS.

Unless anyone has any idea what ELRepo did to my machine?!?

Re: ELRepo broke my laptop keyboard (touchpad works, though, and so does USB keyboard)

Posted: 2020/06/24 22:50:18
by oceanjeremy
Update on this...

The kind folks on the ELRepo mailing list suggested I backup my data, reinstall CentOS and see if I can reproduce the problem. So that's what I'm doing.

Once I figure that out I'll update again here.