Page 1 of 2

RAID support

Posted: 2020/06/09 20:27:38
by filmtools
Hello group,

This is my first time posting. I am a filmmaker so I have a limited knowledge about hardware support. Moving form Windows 10 enterprise to CentOS8 to run DaVinci Resolve. I was able to follow a guide to install everything and now I have my question is RAIDs and cards I have. I am using old HPz800 workstation.

The command for listing raids shows this:

[root@localhost lnx_drv_esasraid_370]# lspci | grep -i raid

00:1f.2 RAID bus controller: Intel Corporation SATA Controller [RAID mode]
03:00.0 RAID bus controller: ATTO Technology, Inc. ExpressSAS R380
28:00.0 RAID bus controller: Broadcom / LSI MegaRAID SAS 2208 [Thunderbolt] (rev 03)

03:00.0 RAID bus controller [0104]: ATTO Technology, Inc. ExpressSAS R380 [117c:002c] - don't see the raid volume from this card.
28:00.0 RAID bus controller [0104]: Broadcom / LSI MegaRAID SAS 2208 [Thunderbolt] [1000:005b] (rev 03) - I see 2 raid volumes under CentOS8
41:00.0 SCSI storage controller [0100]: Broadcom / LSI SAS1068E PCI-Express Fusion-MPT SAS [1000:0058] (rev 08) - don't see the volume in CentOS8

I am able to see the 2 Raid volumes on the LSI Mega Raid SAS2208 card - it is a MegaRAID SAS 9266-8i card. Is this card supported under CentOS8 because I can't find the drivers and the MegaRaid software to control the card. But I can use it under windows or its own bios at boot to manage raids volumes.

ATTO R380 is a Sonnet 3Gb/s SAS/SATA RAID (R380) and the last drivers for it are - Software (Linux) 4.07 found here ... ction=b531

is it possible to make this card work under CentOS8? ReadMe for last driver on that page says it only supports:

Red Hat Enterprise Server Linux 4, 5
SUSE Linux Enterprise Server 10, 11
Fedora 12
openSUSE Linux 11
I was not able to install it under CentOS8 - hope there is a way to do it so I can see the RAID volume under CentOS8

All my raid are NTFS and I can see 2 raids under /dev/sdf1 and /dev/sdf2 on the SAS20208 card at this time.

If you can help me here I would love to switch to CentOS8 for good :)


Re: RAID support

Posted: 2020/06/09 22:06:48
by TrevorH
Google for ELRepo and download their latest elrepo-release.rpm and install it.

One of your controllers is already supported and works. The other LSI controller is probably one of a long list that Red Hat deprecated support for in RHEL 8 but ELRepo supply a kmod-megaraid_sas.x86_64 that adds support back for the ones that were removed. If you install that then you will get access to both LSI controllers.

I did think that ELRepoo provided a kmod package for the ATTO controller too but I don't seem to be able to find it. Google says that uses an esas2r.ko module but nothing supplies that even using ELRepo. One route you could try is raising an RFE ticket on the ELRepo bug tracker and see if they can produce a kmod-esas2r. I suspect this would be the most stable route to use as the CentOS kernel should be more stable than the alternative below.

There is another alternative. ELRepo have also installed an elrepo-kernel repo that is disabled by default. In that disabled repo you will find kernel-lt and kernel-ml packages. The esas2r module is enabled in the kernel-ml package so if you install and boot into that, I believe it should then find all 3 controllers.

Re: RAID support

Posted: 2020/06/10 07:00:18
by filmtools
Thanks for your help. I have seen that ELRepo discussion on one of the pages but I am lost because I am really new to linux. I just downloaded kmod-megaraid_sas-07.707.51.00-1.el8_1.elrepo.x86_64.rpm and when I double click it in the files 3.28.1-stable it opens up the Software 3.30.6 with Install button. When I click that it says 0% then goes back. So I guess its not installing.

Re: RAID support

Posted: 2020/06/10 08:13:20
by TrevorH
Google for ELRepo and download their latest elrepo-release.rpm and install it.
Step 1

Then yum install kmod-megaraid_sas

Re: RAID support

Posted: 2020/06/10 08:56:34
by filmtools
Thanks a lot!

I found that the - kmod-mptsas-3.04.20-2.el8_1.elrepo.x86_64.rpm package is the right one for

[0100]: Broadcom / LSI SAS1068E PCI-Express Fusion-MPT SAS [1000:0058] (rev 08) that is built on the motherboard of a HP z800 workstation and installed it with yum install and rebooted and upon reboot I heard 6 disks spin up :) - it worked!

Now only thing left is to try to find out the elrepo package for the ATTO Technology, Inc. ExpressSAS R380

Under Windows I use Mega Raid Control software to manage raids. Is there anything similar that can work under CentOS8? To manage all RAID volumes?


Re: RAID support

Posted: 2020/06/10 08:59:48
by TrevorH
I'm pretty sure there is no existing kmod package for the ATTO controller so you'll need to ask them if one can be created and hope that it can.

There are rpm packages around from LSI containing MegaCLI or MegaCLI64 executables that will allow you to monitor or manipulate the RAID arrays but I do not think that will be in any repo as it's closed source, manufacturer supplied. It's something you'll have to get from LSI or their successors.

Re: RAID support

Posted: 2020/06/10 09:39:51
by filmtools
I am happy to report that the AVAGO MegaRAID Storage manager v17.05.02.01 installed under CentOS8 and i am able to control all Physical and Logical drives. I had to first get dnf list tcsh and then use ./install.csh - or can be done by manually going in and installing all packages with yum install command. It pulls latest dependencies from the servers.

Thanks a lot for your help TrevorH :)

Now on to making a ticket for the ATTO card and hope that they will make a fix :)

Re: RAID support

Posted: 2020/06/10 18:23:25
by filmtools
I am trying to build the older driver to see if it will work on CentOS8

when I run ./ i get this

ATTO Technology, Inc.
Linux Driver Install Script v2.1

Building and installing the ATTO ESAS RAID driver, please wait...

An error occurred while making the driver

---make output---

---make errors---
make: *** No rule to make target 'install'. Stop.
make: *** Waiting for unfinished jobs....

do I have to do something before hand?

Re: RAID support

Posted: 2020/06/10 18:28:20
by filmtools
[root@localhost Drivers]# cd src
[root@localhost src]# make
This driver only works with Linux kernel version 2.4 or 2.6
You appear to be running kernel version 4.18
make: *** [Makefile:281: checkkernel] Error 1
[root@localhost src]#

Re: RAID support

Posted: 2020/06/10 18:38:05
by TrevorH
It's already part of the mainline kernel so you shouldn't need to compile it yourself. What was the response from ELRepo? Did you try their kernel-ml package yet as that already contains esas2r.ko.