Page 1 of 1

(Solved) NVIDIA RTX 5000 Driver Issue

Posted: 2020/04/26 21:57:42
by AirborneSurveyor
I have a new Dell Precision 7740 with a NVIDIA Quadro RTX 5000.
I tried to install the NVIDIA Linux driver: ... 9360/en-us
With the following errors:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Apr 26 11:44:15 2020
installer version: 440.82

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin

nvidia-installer command line:

Using: nvidia-installer ncurses v6 user interface
-> Detected 16 CPUs online; setting concurrency level to 16.
-> Tagging shared libraries with chcon -t textrel_shlib_t.
-> Installing NVIDIA driver version 440.82.
ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
WARNING: One or more modprobe configuration files to disable Nouveau are already present at: /usr/lib/modprobe.d/nvidia-installer-disable-nouveau.conf, /etc/modprobe.d/nvidia-installer-disable-nouveau.conf. Please be sure you have rebooted your system since these files were written. If you have rebooted, then Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X configuration file. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at

Where do I go from here?


Posted: 2020/04/26 22:54:51
by TrevorH
Use ELRepo's nvidia-detect and kmod-nvidia packages


Posted: 2020/04/26 23:35:22
by AirborneSurveyor
TrevorH wrote:
2020/04/26 22:54:51
Use ELRepo's nvidia-detect and kmod-nvidia packages

Thank you for your fast reply, and I have used your advice in the past and want to thank you for that as well! Could you break it down for me (a.k.a. dumb it down).

I currently use RHEL 6 at work, cut my teeth on Linux - RHEL 5 on the job (2015). Just made the jump to running Linux and my primary OS on my new computer and will run windows in a VM for windows things I need to do. But trying to get things to work in this aspect is above my skill level.


Posted: 2020/04/26 23:57:01
by TrevorH
Google for "ELRepo" and go there. The front page there is either a "getting started" or has a link to it. Install their elrepo-release file for el8, yum install nvidia-detect and once installed, run it and it will tell you which of their kmod-nvidia* packages supports your card then you yum install that one. It does, or should do, everything for you including blacklisting nouveau.


Posted: 2020/04/28 01:51:11
by AirborneSurveyor
On the ELRepo page I followed the instructions for getting started - no issues until:

[root@localhost ~]# yum install nvidia-detect
CentOS-8 - AppStream 396 B/s | 4.3 kB 00:11
CentOS-8 - Base 1.2 kB/s | 3.9 kB 00:03
CentOS-8 - Extras 179 B/s | 1.5 kB 00:08 Community Enterprise Linux Repository - el8 1.1 kB/s | 2.9 kB 00:02
No match for argument: nvidia-detect
Error: Unable to find a match: nvidia-detect

Was at a dead end. Poked around the ELRepo page and found the rpm for my card and remembered at work back when we had RHEL 5 we would always have to drop to single user mode and reinstall the NVIDIA drivers after most patches. So I switch my run level: systemctl set-default - rebooted and logged in as root then installed the rpm. Switched my run level back to and rebooted. This did not fix my problem. However, when I run lspci my graphics card is now listed as a device. This is something that was not there before.

root@localhost ~]# lspci
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (rev 02) <-- What is running
01:00.0 VGA compatible controller: NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] (rev a1) <-- Was not listed before
01:00.1 Audio device: NVIDIA Corporation Device 10f8 (rev a1)
01:00.2 USB controller: NVIDIA Corporation Device 1ad8 (rev a1)
01:00.3 Serial bus controller [0c80]: NVIDIA Corporation Device 1ad9 (rev a1)

I have to call it a night and get back to this tomorrow evening after work.


Posted: 2020/04/28 08:15:39
by TrevorH
when I run lspci my graphics card is now listed as a device. This is something that was not there before.
I suspect you didn't look hard enough before as lspci shows the hardware that's installed and is not affected by what drivers are installed.

It appears that nvidia-detect is in the elrepo-testing repo, not sure why it's not made it out to the main one yet so dnf --enablerepo=ekrepo-testing install nvidia-detect then run nvidia-detect and it should tell you which package to install.

Since you have two graphics cards you may need to use bumblebee bt I don't have any experience with that or the nvidia drivers on CentOS 8 so someone else will need to help.


Posted: 2020/05/01 17:44:38
by AirborneSurveyor
Solved. Was not able to work on this until this morning.
Thank you TrevorH for your assistance.
Ran: yum --enablerepo=elrepo-testing install nvidia-detect This was successful and I ran nvidia-detect. The output told me to install a older driver: yum installkmod-nvidia-440.64 this downgraded: kmod-nvidia-440.82-1.el8_1.elrepo.x86_64 to: kmod-nvidia-440.64-1.el8_1.elrepo.x86_64 Rebooted the machine and nothing changed. So I went into my bios under current configuration listed two video controllers: Intel Corporation UHD Graphics 630 (Moble) (Rev 02) and NVIDIA N19E-Q5. Then I looked under video controller there was a screen "Switchable Graphics" I had the check box "Enabled Switchable Graphics" It stated "It should only be enabled for Windows 7 and later version of Windows or the Ubuntu OS. The feature is not applicable to other Operating Systems." So I unchecked that box and checked the box "Discrete Graphics Controller Direct Output Mode." Saved my settings and this changed my Video Controller to just NVIDIA N19E-Q5 the Intel controller was no longer listed. Rebooted and this made a significant change to my display for the better. However under Settings-About-Graphics: llvmpipe (LLM 8.0, 256 bits) was listed. No NVIDIA Controls were available under Applications. So I re-installed: rpm -U kmod-nvidia-440.82-1.el8_1.elrepo.x86_64.rpm Rebooted nothing changed. I started googling nvidia control and nvidia control panel packages came up. I read that I need to run "nvidia-settings" This erred out. So I ran yum whatprovides nvidia-settings one of the results was matching my rpm driver I installed so: yum install nvidia-x11-drv-440.82-1.el8_1.elrepo.x86_64 Reboot and success!