CENTOS 8 Weird Opening (NVIDIA)

Issues related to hardware problems
Post Reply
mesasa
Posts: 2
Joined: 2020/03/31 20:59:01

CENTOS 8 Weird Opening (NVIDIA)

Post by mesasa » 2020/03/31 21:47:32

HI, I have a 4k, i9 laptop which has

Code: Select all

lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation TU106BM [GeForce RTX 2070 Mobile] (rev a1)
.

I am quite new in linux world, and I decided to install dual boot with UEFI WIN10 with Centos8 to my M.2 main drive.
When I selected the partittion for my centos, I chose existing windows /boot/efi drive and mount it. plus I have brand new /boot drive, /root drive and /home drive.

Everything was fine till NVIDIA driver.. I had almost try all posibilities. and ended up with;
my "./boot/efi/EFI/centos/grub.cfg " file has;
set default_kernelopts="root=UUID=19e703fe-8d84-481b-8371-0b6385dbd1ea ro crashkernel=auto resume=UUID=42b9dfa9-1cc7-4776-b503-bede257cf9e3 nomodeset rhgb quiet systemd.unit=multi-user.target "
line.

I need to add " systemd.unit=multi-user.target " line. becasue if it starts normal graphical target, after gnome login menu its gone completely black. and ALT F2 doesnt work its basically frozen. and login bars are extreemly big on that type login.
but if I change "grub" line as a multiuser' after login in command line' I could shift back to graphical interface with " startx " command.

My question is:
I am going to install my video softwares and setups everything related with my job. Should I expect further problems about this issue? OR what I might have done different?

driver I used: NVIDIA-Linux-x86_64-440.64.run

User avatar
TrevorH
Forum Moderator
Posts: 29136
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CENTOS 8 Weird Opening (NVIDIA)

Post by TrevorH » 2020/03/31 22:07:06

We don't generally recommend using the .run file. Did you blacklist nouveau? Doesn't look like you added the rd.driver.blacklist=nouveau to the kernel command line either.

Usually we point people to the ELREpo kmod-nvidia packages which do it all for you.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

mesasa
Posts: 2
Joined: 2020/03/31 20:59:01

Re: CENTOS 8 Weird Opening (NVIDIA)

Post by mesasa » 2020/04/02 01:52:24

of course I tried that as well, here is the output for elrepo

Code: Select all

# yum install nvidia-detect
Last metadata expiration check: 7:18:08 ago on Wed 01 Apr 2020 18:22:28 BST.
No match for argument: nvidia-detect
I couldn't continue with this method unfortunately

User avatar
jlehtone
Posts: 2934
Joined: 2007/12/11 08:17:33
Location: Finland

Re: CENTOS 8 Weird Opening (NVIDIA)

Post by jlehtone » 2020/04/02 08:12:20

The detect is still in testing:

Code: Select all

$ sudo dnf -q --enablerepo=elrepo\* list \*nvidia\*
Available Packages
kmod-nvidia.x86_64                                  440.64-1.el8_1.elrepo                     elrepo        
kmod-nvidia-390xx.x86_64                            390.132-1.el8_1.elrepo                    elrepo        
nvidia-detect.x86_64                                440.64-1.el8                              elrepo-testing
nvidia-x11-drv.x86_64                               440.64-1.el8_1.elrepo                     elrepo        
nvidia-x11-drv-390xx.x86_64                         390.132-1.el8_1.elrepo                    elrepo        
nvidia-x11-drv-390xx-libs.i686                      390.132-1.el8_1.elrepo                    elrepo        
nvidia-x11-drv-390xx-libs.x86_64                    390.132-1.el8_1.elrepo                    elrepo        
nvidia-x11-drv-libs.i686                            440.64-1.el8_1.elrepo                     elrepo        
nvidia-x11-drv-libs.x86_64                          440.64-1.el8_1.elrepo                     elrepo        
pcp-pmda-nvidia-gpu.x86_64                          4.3.2-2.el8                               AppStream
Date on kmod-nvidia is 2020-04-01 (yesterday).
Date on kmod-nvidia-390xx is 2020-03-30 (hadn't even seen it in testing).

Post Reply

Return to “CentOS 8 - Hardware Support”