Touchpad isn't working on CentOS 8

Issues related to hardware problems
Post Reply
mgoblue0970
Posts: 37
Joined: 2013/01/02 03:39:20

Touchpad isn't working on CentOS 8

Post by mgoblue0970 » 2020/02/08 03:42:46

Hi all:

The title says it all. I just installed CentOS 8 on my laptop and the touchpad isn't working. Like many, I hate the touchpad but for times like when I'm on an airplane there often isn't room for a mouse.

Speaking of a mouse, my USB mouse works just fine... just don't have the same luck with the touchpad. I tried running

Code: Select all

synclient -l
and got

Code: Select all

command not found...
So I ran

Code: Select all

yum search synaptics
and got

Code: Select all

No matches found.
Grr.

Attaching the output from hwinfo to this post.

xinput:

Code: Select all

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ xwayland-pointer:16                     	id=6	[slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:16            	id=7	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ xwayland-keyboard:16                    	id=8	[slave  keyboard (3)]

less /proc/bus/input/devices | grep -i touch:

Code: Select all

N: Name="ELAN1300:00 04F3:3057 Touchpad"
A ha! Perhaps we are on to something here.

So I ran the following five commands and didn't get any output:

lspci | grep -i elan
lspci | grep -i touch
lsusb | grep -i elan
lsusb | grep -i touch
lsmod | grep -i elan

Are there any other commands I should run which would shed some light on what is going on?

When I Google "elan touchpad linux driver" I cannot find squat. Is there a driver/package/etc., out there for this device?

Thanks in advance for any assistance you can provide.
Attachments
hwinfo.zip
(56.01 KiB) Downloaded 36 times

User avatar
TrevorH
Forum Moderator
Posts: 28884
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Touchpad isn't working on CentOS 8

Post by TrevorH » 2020/02/08 11:29:19

Does it work if you use xorg instead of wayland?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

mgoblue0970
Posts: 37
Joined: 2013/01/02 03:39:20

Re: Touchpad isn't working on CentOS 8

Post by mgoblue0970 » 2020/02/08 17:07:15

Thanks for the reply. But I don't understand it :)
How does one specify xorg over wayland. I don't know the difference quite honestly.

sml
Posts: 113
Joined: 2020/01/17 09:01:44

Re: Touchpad isn't working on CentOS 8

Post by sml » 2020/02/08 21:11:18

On your login screen when it shows the input field for password there's a gear symbol to the left of the Sign In button:
Image
Click on the gear and select the line with X11 and/or Xorg in it (the image above is for Arch Linux, not for CentOS, so your options will be named differently).

On another note,
mgoblue0970 wrote:
2020/02/08 03:42:46
less /proc/bus/input/devices | grep -i touch:

Code: Select all

N: Name="ELAN1300:00 04F3:3057 Touchpad"
A ha! Perhaps we are on to something here.

So I ran the following five commands and didn't get any output:

lspci | grep -i elan
lspci | grep -i touch
lsusb | grep -i elan
lsusb | grep -i touch
You've got the Vendor:Device pair shown, so it's

Code: Select all

lspci -d 04f3:3057
lsusb -d 04f3:3057
Although that wouldn't give you anything. Linux Hardware lists it neither as PCI nor as USB, but as PS/2 :twisted: . In fact, it's I2C, so try to install i2c-tools:

Code: Select all

dnf install i2c-tools
modprobe i2c-dev
i2cdetect -l
Does it show up in the output of libinput list-devices (on Wayland)?

Also, from ArchWiki:
If it is an Elantech Touchpad not being detected and you are getting the following line in your journalctl -k:

Code: Select all

elan_i2c 5-0015: 5-0015 supply vcc not found, using dummy regulator
it is related to an issue with the psmouse module trying to use a secondary bus for the touchpad device, and elan_i2c failing to do so. The fix is to force it to use the primary one. Just create the file below and reload the psmouse module or reboot:

/etc/modprobe.d/psmouse.conf

Code: Select all

options psmouse elantech_smbus=0
There're also some arcane kernel boot parameters for the i8042 controller like i8042.noaux, i8042.noloop, i8042.nomux, i8042.nopnp, i8042.reset that are discussed here.

mgoblue0970
Posts: 37
Joined: 2013/01/02 03:39:20

Re: Touchpad isn't working on CentOS 8

Post by mgoblue0970 » 2020/02/09 04:40:20

Thanks for the detailed reply. Much appreciated!

I ran:

Code: Select all

dnf install i2c-tools
modprobe i2c-dev
i2cdetect -l
as you mentioned... and
Does it show up in the output of libinput list-devices (on Wayland)?
here's the notable output:

Code: Select all

Device:           ELAN1300:00 04F3:3057 Touchpad
Kernel:           /dev/input/event13
Group:            8
Seat:             seat0, default
Size:             103x69mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a
So I guess that's something.

I ran:

Code: Select all

journalctl -k | grep -i elan

Code: Select all

Feb 06 03:28:11 localhost.localdomain kernel: input: ELAN1300:00 04F3:3057 Mouse as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-6/i2c-ELAN1300:00/0018:04F3:3057.0004/input/input14
Feb 06 03:28:11 localhost.localdomain kernel: input: ELAN1300:00 04F3:3057 Touchpad as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-6/i2c-ELAN1300:00/0018:04F3:3057.0004/input/input15
Feb 06 03:28:11 localhost.localdomain kernel: hid-generic 0018:04F3:3057.0004: input,hidraw3: I2C HID v1.00 Mouse [ELAN1300:00 04F3:3057] on i2c-ELAN1300:00
Feb 06 03:28:12 localhost.localdomain kernel: input: ELAN1300:00 04F3:3057 Touchpad as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-6/i2c-ELAN1300:00/0018:04F3:3057.0004/input/input24
Feb 06 03:28:12 localhost.localdomain kernel: hid-multitouch 0018:04F3:3057.0004: input,hidraw3: I2C HID v1.00 Mouse [ELAN1300:00 04F3:3057] on i2c-ELAN1300:00
Rebooting did not work

Creating /etc/modprobe.d/psmouse.conf with options psmouse elantech_smbus=0 in the file did not work.

Changing the server from wayland to xorg did not work.

Post Reply

Return to “CentOS 8 - Hardware Support”