Intel Wireless 4965 AGN not detected in CentOS 8

Issues related to hardware problems
Post Reply
Posts: 2
Joined: 2020/02/03 16:02:11

Intel Wireless 4965 AGN not detected in CentOS 8

Post by dj04 » 2020/02/03 17:22:42

Trying to enable Intel 4965 on a Dell Laptop with a newly installed CentOS 8 - with no luck so far.
-lspci -nn returns
0c:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection [8086:4229] (rev 61)
Having recd. a no output on
-grep -i 8086 /lib/modules/4.18.0-147.el8.x86_64/modules.* | grep -i 4229
I've opted to get an updated firmware version from ELRepo Extras x86_64.
-rpm -Uvh elrepo-release*rpm
-dnf --enablerepo=elrepo-extras install iwl4965-firmware
This has resulted in
Module Size Used by
iwlwifi 286720 0
cfg80211 794624 1 iwlwifi

After several restarts CentOS 8 is still struggling to enable the builtin wireless interface.

Am new to CentOS and would really like to get things moving with my LT. Let me know what additional steps needed to break this deadlock.

Thanks in advance.

User avatar
Forum Moderator
Posts: 28511
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Intel Wireless 4965 AGN not detected in CentOS 8

Post by TrevorH » 2020/02/03 17:39:07

Try installing elrepo-release and then installing this package:

Code: Select all

Name         : kmod-iwlegacy
Version      : 0.0
Release      : 2.el8_1.elrepo
Architecture : x86_64
Size         : 194 k
Source       : kmod-iwlegacy-0.0-2.el8_1.elrepo.src.rpm
Repository   : elrepo
Summary      : iwlegacy kernel module(s)
URL          :
License      : GPLv2
Description  : This package provides the iwlegacy kernel module(s).
             : It is built to depend upon the specific ABI provided by a range of releases
             : of the same variant of the Linux kernel and not on any one specific build.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Posts: 2
Joined: 2020/02/03 16:02:11

Re: Intel Wireless 4965 AGN not detected in CentOS 8

Post by dj04 » 2020/02/04 12:39:09


Many thanks for the quick reply.

In fact I've tried your suggestion and its still the same. I've installed the rpm version and wonder if there's a conflict between the previously installed elrepo extras firmware (dnf --enablerepo=elrepo-extras install iwl4965-firmware) and the legacy kernel module.

Any more suggestions are greatly appreciated.


Post Reply

Return to “CentOS 8 - Hardware Support”