[Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Issues related to hardware problems
MagnusStockholm
Posts: 6
Joined: 2019/12/24 06:49:02

[Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by MagnusStockholm » 2019/12/24 07:05:28

I have a really nice i7 motherboard with dual Marvel 88E8056 Gigabit Ethernet chips in the chipset that I would like to run CentOS 8 on. However these Ethernet chips are no longer supported (I have even looked into building driver from sources but have not found one for current kernel version).

Is this an impossible task or is anyone aware of some solution?

User avatar
TrevorH
Forum Moderator
Posts: 29171
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by TrevorH » 2019/12/24 12:03:27

It appears to be one of the cards deprecated by RH in RHEL 8. If anyone will do a driver package for it, it will be ELRepo. They have a bug tracker, suggest you raise an RFE request there and ask. In CentOS 7 it's supported by the sky2 module... oh, wait, you don't need the RFE, you just need ELRepo installed and then install

Code: Select all

kmod-sky2.x86_64                  1.30-1.el8_0.elrepo                         elrepo         
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

MagnusStockholm
Posts: 6
Joined: 2019/12/24 06:49:02

Re: Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by MagnusStockholm » 2019/12/25 16:01:07

Thanks a lot - I was under the false impression the Marvel chip was supported by sk98lin (claimed in some post I goggled up) and it is this one I have been hunting for a kernel 4.XX version of. I even had ELRepo set up (that is where sk98lin resides for the 3.xx kernels) so just had to "USB tather" with my phone and install (sudo yum install kmod-sky2.x86_64) and problem solved :D

100os
Posts: 6
Joined: 2019/02/09 20:55:57

Re: [Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by 100os » 2020/01/17 03:06:18

Greetings all.

I'm running a Asus Crosshair IV Mobo with a AMD Phenom 1090T hexcore with a Marvell 8059 Gigabit LAN controller (Yukon), all in a headless server. This is of not-so-old vintage, approximately 2011, so I was surprised that the NIC chip was considered deprecated...

I had figured out essentially the same solution as described above, for the initial installation in December, all was well.

Today, upon rebooting with the new kernel (4.18.0-147.3.1.el8_1.x86_64) networking is down.

"ip a" and "ifconfig" shows the loopback, but not the NIC.

lshw shows: *ethernet UNCLAIMED

When trying to reinstall the kmod-sky2 rpm file, I was looping around: "rpm - i" would tell me that it was already installed, but "rpm -e" would tell me it was not installed, so nothing to remove.

I figured out that "rpm --reinstall" would force a reinstall, but that didn't help ultimately, because networking is still not working under the new kernel.

Rebooting to the previous kernel (4.18.0-80.11.2) and the network is back, not ideal, but at least I'm up.

Does anyone have a suggestion to get the NIC working under the new kernel and to keep it working for future kernel updates?

Thanks

Wiboolean
Last edited by 100os on 2020/01/17 22:37:32, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 29171
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: [Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by TrevorH » 2020/01/17 07:16:04

I would suggest asking ELRepo if their kmod-sky2 needs rebuilding for the new 8.1 kernels.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

NedSlider
Forum Moderator
Posts: 2896
Joined: 2005/10/28 13:11:50
Location: UK

Re: [Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by NedSlider » 2020/01/17 19:00:09

I will rebuild kmod-sky2 for el8.1 for you and post back here once done

100os
Posts: 6
Joined: 2019/02/09 20:55:57

Re: [Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by 100os » 2020/01/17 22:36:55

very much appreciated - thanks for the support.

wiboolean

NedSlider
Forum Moderator
Posts: 2896
Joined: 2005/10/28 13:11:50
Location: UK

Re: [Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by NedSlider » 2020/01/18 16:34:19

kmod-sky2-1.30-2.el8_1.elrepo.x86_64.rpm has been built and released to the main elrepo repository for el8.1. It should be available on mirror sites shortly.

Please let me know if you have any issues :)

100os
Posts: 6
Joined: 2019/02/09 20:55:57

Re: [Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by 100os » 2020/01/18 19:21:45

So far... Works like a charm!!! :D :D :D 8-) 8-) 8-)

Thanks again for the support and the quick turn around on this issue.

Wiboolean

trusso
Posts: 3
Joined: 2020/02/22 19:49:27

Re: [Solved] Marvel 88E8056 Gigabit NIC in CentOS 8?

Post by trusso » 2020/02/22 20:22:11

Great work!

But it doesn't work anymore with the latest kernel. :D Would be ideal if this package could rebuild the driver at every kernel update.
Could you maybe post here build instructions/steps ?

Thank you!

Post Reply

Return to “CentOS 8 - Hardware Support”