intel 10400 with UHD 630 graphics card - centos 8 stream problem

Issues related to hardware problems
Post Reply
Posts: 2
Joined: 2021/04/05 15:23:22

intel 10400 with UHD 630 graphics card - centos 8 stream problem

Post by steven88 » 2021/04/05 15:36:44

Hi everyone,

I have a new set up with the following parts:
  • motherboard: asrock B560M Steel Legend
  • CPU: Intel Core i5 10400
  • Memory: 16GB Kingston 3200 MHz
I have experienced some problems during the installation and after that (I installed the centos 8 stream as server with GUI)

The boot pendrive was made by rufus 3.1 with default settings. The installer appearance with black background and If I select the first possibility (Install Centos) then the monitor switched off.
Finally I succeeded start the installer with basic graphics mode and I installed the system properly.

I experienced the first strange thing after the first boot when I realized I can only use the display with 800x600 resolution (only this one possibility was available.)

I knew it is needed install the proper driver for integrated video card because I would like to use intel hardware acceleration.
I did the following steps:
  • I modified the GRUB_CMDLINE_LINUX value in the /etc/default/grub file. I removed the nomodest word and I added the i915.alpha_support=1
  • As the proper intel media driver isn't available for centos 8 I build from source the necessary dependencies so I installed from source the libva, libva-utils, gmmlib, libva-media-driver
After these steps I got the expected result from vainfo and the hardware acceleration is worked fine.

I did the above steps via ssh. When I would have liked to use the system with GUI I realized that it haven't any signal with hdmi so I just saw black screen. I tried to reboot the system more times but the everytime the monitor switched off while the system works properly and it reachable via ssh.

On the other hand, I realized the following error message during boot:
core: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee0000000040110a
core: [Hardware Error]: TSC 0 ADDR fef20000 MISC 43880000086
core: [Hardware Error]: PROCESSOR 0:a0655 TIME 1617631222 SOCKET 0 APIC 0 microcode e2

I tried the system with other monitor and the behavior is the same.

As I got a "hardware error" message I figured out I install windows system and I will run diagnostics on it. I did it and haven't found any problems with CPU and memory. So I think it isn't any problem with parts.

In currently, I reinstalled the system and I haven't done any other modification so I can use the system with 800x600 resolution without Hardware accelerating. I checked the boot log with journalctl -xb command and the above error message there is in.

I know this story can be chaotic but I did these things and I considered it important write all things what I experienced to write the real circumstances.

I think can be the start point the follows:
  • my configuration consists the above parts
  • I could install the system only with basic graphics mode
  • new installation from centos 8 stream server with GUI
  • currently I can use the system only with 800x600 resolution
  • I got the above error message during boot.
My purposes are the next:
  • use the system with modifiable resolution
  • use the intel hardware acceleration
  • I want to solve the boot error to disappear the above message
Is there anybody who experienced these things and can help me.

Thanks in advance and looking forward to your reply.

Posts: 2
Joined: 2021/04/05 15:23:22

Re: intel 10400 with UHD 630 graphics card - centos 8 stream problem

Post by steven88 » 2021/04/05 17:47:32

I forget to write that I have an old VGA (Geforce GTS 450). I tried the installation with this card. The same pendrive could boot the installer properly and finally I could use any resolution but the CPU error message there is in system log.
Of course this is not a useable solution for me because this card doesn't support transcoding with hardware acceleration but it was good for test.

Post Reply

Return to “CentOS 8 - Hardware Support”