Is Podman 5.0 coming to CentOS Stream 9?

Issues related to applications and software problems and general support
Post Reply
sigulete
Posts: 1
Joined: 2024/02/20 00:27:58

Is Podman 5.0 coming to CentOS Stream 9?

Post by sigulete » 2024/02/20 00:32:51

I'm looking for some new features that Podman 5.0 is bringing.
Anyone knows if it is going to be available in CentOS Stream 9?

jdanek
Posts: 2
Joined: 2024/05/24 18:46:55

Re: Is Podman 5.0 coming to CentOS Stream 9?

Post by jdanek » 2024/05/24 18:57:24

Yes, probably CentOS Stream 9.5, according to https://github.com/containers/podman/discussions/22592

I am already using in on RHEL 9.4, after I found a build at https://kojihub.stream.centos.org/koji/ ... ldID=61248 and installed it with

Code: Select all

$ sudo dnf install https://kojihub.stream.centos.org/kojifiles/packages/podman/5.0.2/1.el9/x86_64/podman-5.0.2-1.el9.x86_64.rpm
Last metadata expiration check: 0:34:27 ago on Fri May 24 14:05:03 2024.
podman-5.0.2-1.el9.x86_64.rpm                                                                                                                                                                               166 MB/s |  16 MB     00:00    
Dependencies resolved.
============================================================================================================================================================================================================================================
 Package                                             Architecture                                 Version                                                            Repository                                                        Size
============================================================================================================================================================================================================================================
Installing dependencies:
 passt                                               x86_64                                       0^20231204.gb86afe3-1.el9                                          rhel-9-Server-appstream-os                                       190 k
 passt-selinux                                       noarch                                       0^20231204.gb86afe3-1.el9                                          rhel-9-Server-appstream-os                                        32 k
Downgrading:
 podman                                              x86_64                                       2:5.0.2-1.el9                                                      @commandline                                                      16 M

Transaction Summary
============================================================================================================================================================================================================================================
Install    2 Packages
Downgrade  1 Package

Total size: 16 M
Total download size: 222 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): passt-selinux-0^20231204.gb86afe3-1.el9.noarch.rpm                                                                                                                                                   271 kB/s |  32 kB     00:00    
(2/2): passt-0^20231204.gb86afe3-1.el9.x86_64.rpm                                                                                                                                                           1.2 MB/s | 190 kB     00:00    
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                       1.4 MB/s | 222 kB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                                                                    1/1 
  Installing       : passt-0^20231204.gb86afe3-1.el9.x86_64                                                                                                                                                                             1/4 
  Running scriptlet: passt-selinux-0^20231204.gb86afe3-1.el9.noarch                                                                                                                                                                     2/4 
  Installing       : passt-selinux-0^20231204.gb86afe3-1.el9.noarch                                                                                                                                                                     2/4 
  Running scriptlet: passt-selinux-0^20231204.gb86afe3-1.el9.noarch                                                                                                                                                                     2/4 
  Downgrading      : podman-2:5.0.2-1.el9.x86_64                                                                                                                                                                                        3/4 
  Running scriptlet: podman-4:4.9.4-3.el9_4.x86_64                                                                                                                                                                                      4/4 
  Cleanup          : podman-4:4.9.4-3.el9_4.x86_64                                                                                                                                                                                      4/4 
  Running scriptlet: passt-selinux-0^20231204.gb86afe3-1.el9.noarch                                                                                                                                                                     4/4 
  Running scriptlet: podman-4:4.9.4-3.el9_4.x86_64                                                                                                                                                                                      4/4 
  Verifying        : podman-2:5.0.2-1.el9.x86_64                                                                                                                                                                                        1/4 
  Verifying        : podman-4:4.9.4-3.el9_4.x86_64                                                                                                                                                                                      2/4 
  Verifying        : passt-selinux-0^20231204.gb86afe3-1.el9.noarch                                                                                                                                                                     3/4 
  Verifying        : passt-0^20231204.gb86afe3-1.el9.x86_64                                                                                                                                                                             4/4 

Downgraded:
  podman-2:5.0.2-1.el9.x86_64                                                                                                                                                                                                               
Installed:
  passt-0^20231204.gb86afe3-1.el9.x86_64                                                                           passt-selinux-0^20231204.gb86afe3-1.el9.noarch                                                                          

Complete!

User avatar
TrevorH
Site Admin
Posts: 33273
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Is Podman 5.0 coming to CentOS Stream 9?

Post by TrevorH » 2024/05/24 19:23:34

Bit odd that the epoch is wrong on that so it shows up as a downgrade not an upgrade. Also means that any yum update will back that out if it's isn't excluded.
The future appears to be RHEL or Debian. I think I'm going Debian.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are deadest, do not use them.
Use the FAQ Luke

jdanek
Posts: 2
Joined: 2024/05/24 18:46:55

Re: Is Podman 5.0 coming to CentOS Stream 9?

Post by jdanek » 2024/05/25 09:34:52

Installing random packages from the CentOS buildservice onto RHEL is always a risky desperate move. I'll mention to somebody the downgrade thing, that's indeed look wrong. Thanks for raising it.

Post Reply