Yubikey in authentication in CentOS 8

Issues related to applications and software problems and general support
Post Reply
Posts: 1
Joined: 2023/09/18 11:51:17

Yubikey in authentication in CentOS 8

Post by rcgrar014 » 2023/09/18 12:23:52

Good morning.

I am in a project where we want to use a Yubikey like second factor to authenticate the users in CentOS.
We have a closed network (without internet connection) with several CentOS (clients) that authenticate users against a CentOS server with an OpenLDAP. We are using the gnome version.
In that way, We tried to use the OTP mode of yubikeys, but we need access to Internet to send and receive requests from an API.
Later we tried to use the challenge-responde mode, but is only valid for local users (not users located in an openLDAP).
Now, we are trying to use the PIV mode, with a PKI and make the authentication with smartcards, but we can't reach that the VM where we are testing read the Yubikeys obtaining a message that said (This smartcard is not valid, please insert another smartcard).

How can use Yubikeys in our project?

Thanks and regards.

Post Reply