Error after updated glibc-minimal-langpack;2.28-225

Issues related to applications and software problems and general support
Post Reply
phidalgom
Posts: 2
Joined: 2023/05/17 10:19:15

Error after updated glibc-minimal-langpack;2.28-225

Post by phidalgom » 2023/05/17 10:24:57

After a microdnf clean all, my pipeline its failing because a change on glibc-minimal-langpack;2.28-225.el8 version. glibc-2.28-211 works fine but when upgrade to glibc-2.28-225 then it's unable to find some package like:
.....
11:20:03 error: Could not depsolve transaction; 9 problems detected:
11:20:03 Problem 1: package audit-libs-3.0.7-4.el8.x86_64 requires libc.so.6()(64bit), but none of the providers can be installed
11:20:03 - package audit-libs-3.0.7-4.el8.x86_64 requires libc.so.6(GLIBC_2.14)(64bit), but none of the providers can be installed
.....
This was the upgrade
.........
11:15:33 Upgrading:
11:15:33 glibc-2.28-225.el8.x86_64 ubi-8-baseos-rpms 2.3 MB
11:15:33 replacing glibc-2.28-211.el8.x86_64
........
11:17:39 Installing: bzip2;1.0.6-26.el8;x86_64;ubi-8-baseos-rpms
11:17:40 Updating: glibc-minimal-langpack;2.28-225.el8;x86_64;ubi-8-baseos-rpms
11:17:40 Cleanup: libmount;2.32.1-39.el8_7;x86_64;installed
.....
Any clue?
Thanks

User avatar
TrevorH
Site Admin
Posts: 33265
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error after updated glibc-minimal-langpack;2.28-225

Post by TrevorH » 2023/05/17 13:24:56

Is this Stream? Or RHEL?

Did you try yum clean all then give it another go?
The future appears to be RHEL or Debian. I think I'm going Debian.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are deadest, do not use them.
Use the FAQ Luke

phidalgom
Posts: 2
Joined: 2023/05/17 10:19:15

Re: Error after updated glibc-minimal-langpack;2.28-225

Post by phidalgom » 2023/05/17 16:33:58

Solved.
By the way, thank you @TrevorH with yum I supposed it solves too.

This was a microdnf problem with libraries order in clean all.

It is fixed using dnf clean all

User avatar
TrevorH
Site Admin
Posts: 33265
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error after updated glibc-minimal-langpack;2.28-225

Post by TrevorH » 2023/05/17 17:01:45

On versions >= 8, yum is dnf and dnf is yum. It's a symlink.
The future appears to be RHEL or Debian. I think I'm going Debian.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are deadest, do not use them.
Use the FAQ Luke

Post Reply