aarch64 Installation Fails: Warning /dev/root does not exist

Issues related to applications and software problems and general support
Post Reply
Posts: 1
Joined: 2021/02/23 16:27:26

aarch64 Installation Fails: Warning /dev/root does not exist

Post by vlawn » 2021/02/23 16:35:46

I have tried this with RHEL-7/8 and CentOS-7/8 resulting in failure. Trying the same steps with Ubuntu 20.04 results in a successful installation.

Platform is an NXP Layerscape board using UEFI fw.

I used dd to write the aarch64 DVD ISO to a USB drive. I also tried by using Rufus.

I choose the USB drive in the UEFI boot devices menu and Grub shows up. I have tried all three grub entries with no change in result. The kernel is loaded and starts to boot and then hangs with the message:

Code: Select all

[  OK  ] Reached target Basic System.
After about two minutes, this message is printed a bunch of times:

Code: Select all

[  160.232068] dracut-initqueue[1039]: Warning: dracut-initqueue timeout - starting timeout scripts
And then finally I am left with this before being presented with:

Code: Select all

[  231.551903] dracut-initqueue[1039]: Warning: Could not boot.
         Starting Setup Virtual Console...
[  OK  ] Started Setup Virtual Console.
         Starting Dracut Emergency Shell...
Warning: /dev/root does not exist

Generating "/run/initramfs/rdsosreport.txt"

Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report.

I have tried editing grub.cfg to set root to the UUID instead of the label. I tried booting from the grub command line, loading the kernel and initrd manually and setting root manually.
It all leads to the same result.

Any idea what's going on or what to try next?

Post Reply

Return to “CentOS 8 - General Support”