PSA: are you aware of /var/lib/dnf/modulefailsafe?

Issues related to applications and software problems and general support
Post Reply
aalba6775
Posts: 6
Joined: 2019/09/25 00:54:23

PSA: are you aware of /var/lib/dnf/modulefailsafe?

Post by aalba6775 » 2021/02/19 06:48:34

PSA: modulefailsafe/ "lock" files can prevent non-modular packages to upgrade modular packages.

When libuv-1.38 AppStream/Devel were not in sync, I used (modular) libuv-devel-1.36 from EPEL.
When AppStream/Devel libuv-1.38 were finally in sync, I tried to upgrade to 1.38 but it was always filtered out by module (black) magic.

I even resorted to removing all reference to the EPEL repos but still no go.

It turns out installing modular libuv-devel from EPEL had installed this file:

/var/lib/dnf/modulefailsafe/libuv:epel8-buildroot:x86_64.yaml

This was not removed with "dnf clean all" nor by the removal of EPEL versions of libuv/libuv-devel-1.36. The presence of this file prevented the installation of non-modular 1.38. This was a tear-my-hair-out moment.

Just to spare you future grief...

Post Reply

Return to “CentOS 8 - General Support”