Error - "No Package MySQL-python avaiable". How to fix this?

Issues related to applications and software problems and general support
Post Reply
prabha_friend
Posts: 49
Joined: 2020/06/10 14:05:16

Error - "No Package MySQL-python avaiable". How to fix this?

Post by prabha_friend » 2020/10/17 17:19:37

[root@localhost playbooks]# ansible-playbook starfish.yml
[DEPRECATION WARNING]: The firewalld module has been moved to the ansible.posix
collection. This feature will be removed from community.general in version
2.0.0. Deprecation warnings can be disabled by setting
deprecation_warnings=False in ansible.cfg.

PLAY [starfish] ****************************************************************

TASK [Gathering Facts] *********************************************************
ok: [localhost]

TASK [Install epel-release] ****************************************************
ok: [localhost]

TASK [Install dependencies] ****************************************************
fatal: [localhost]: FAILED! => {"changed": false, "failures": ["No package MySQL-python available."], "msg": "Failed to install some of the specified packages", "rc": 1, "results": []}

PLAY RECAP *********************************************************************
localhost : ok=2 changed=0 unreachable=0 failed=1 skipped=0 rescued=0 ignored=0

[root@localhost playbooks]#

User avatar
TrevorH
Forum Moderator
Posts: 29719
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error - "No Package MySQL-python avaiable". How to fix this?

Post by TrevorH » 2020/10/17 17:32:01

Code: Select all

[root@centos8 ~]# dnf list \*mysql\* | grep -i py
python-mysqlclient-doc.x86_64     1.4.6-2.el8                          epel           
python2-PyMySQL.noarch            0.8.0-10.module_el8.2.0+381+9a5b3c3b AppStream      
python3-PyMySQL.noarch            0.8.0-10.module_el8.1.0+245+c39af44f AppStream      
python3-aiomysql.noarch           0.0.20-2.el8                         epel           
python3-mysql.x86_64              1.4.6-5.el8                          epel           
python3-mysql-debug.x86_64        1.4.6-5.el8                          epel           
python3-mysqlclient.x86_64        1.4.6-2.el8                          epel
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

prabha_friend
Posts: 49
Joined: 2020/06/10 14:05:16

Error - No package MySQL-python available

Post by prabha_friend » 2020/10/20 14:58:03

Okay. Yesterday we solved the below topic by changing all the "pip" Keywords to "pip3" and also from "python-pip" command to "python3-pip" command.
viewtopic.php?f=54&t=76065

Like that, today I have a Playbook with me which gives the below error message...

No package MySQL-python available

What to change in the playbook to make it work like the changes we made in the group command to work???

Hope you reply,
Prabhakaran

ps:
Attaching the error screenshot and also
The Playbook: starfish.yml
Attachments
starfish.zip
Password changed
(1.44 KiB) Downloaded 1 time
No package MySQL-python available
No package MySQL-python available
Error_on_Starfish.PNG (78.52 KiB) Viewed 170 times

User avatar
TrevorH
Forum Moderator
Posts: 29719
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error - "No Package MySQL-python avaiable". How to fix this?

Post by TrevorH » 2020/10/20 15:07:48

Please don't make duplicate posts.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

prabha_friend
Posts: 49
Joined: 2020/06/10 14:05:16

Re: Error - "No Package MySQL-python avaiable". How to fix this?

Post by prabha_friend » 2020/10/20 15:29:15

TrevorH wrote:
2020/10/20 15:07:48
Please don't make duplicate posts.
Dear Mr.Trevor,
I am extremely sorry that this question have made a Duplicate Entry. My real intention is not that. I thought making a separate topic referring the to the way the earlier topic has been successfully solved can make this playbook fixation Easy. That's why I made a separate post referring the earlier one. These are only initial troubles. My purpose is not to learn/Master the centOS but just to setup an Asterisk Server Successfully. I am in a transit position only.

I sincerely request all our forum members to show me some light on how to make that Playbook run (starfish.yml)

I just need a revised version (fixed) of that Playbook. After that I will proceed with community.asterisk.org and deal with them only. Just one final favor: Someone please fix the playbook and share. Thank You.

With Hope,
Prabhakaran

Post Reply

Return to “CentOS 8 - General Support”