Going nuts: How to get python 3.7.6 installed on CentOS 8

Issues related to applications and software problems and general support
Post Reply
Halverson44
Posts: 1
Joined: 2020/10/14 06:48:28

Going nuts: How to get python 3.7.6 installed on CentOS 8

Post by Halverson44 » 2020/10/14 06:50:46

I have tried many ways of installing python3.7.6 on centos 7.

Regardless of what I do, I always get the error that the SSL module is not available.

I have tried basic install guides such as https://tecadmin.net/install-python-3-7-on-centos/ (short story: yum install openssl-devel, configure, make install)

One with manual/updated changes to the build files (https://joshspicer.com/python37-ssl-issue)

I've downloaded and built openssl myself, then tried to configure/build python with --with-openssl

No go.

Any other ideas? If it were really this hard, no one would be using it, so I must have something special going on

User avatar
TrevorH
Forum Moderator
Posts: 29719
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Going nuts: How to get python 3.7.6 installed on CentOS 8

Post by TrevorH » 2020/10/14 06:59:48

The standard python 3.6 version of CentOS 8 is already 3.6.8 and you cannot change it. It should already be installed

dnf module enable python36
dnf install python36

Source installs should not be performed
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
jlehtone
Posts: 3107
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Going nuts: How to get python 3.7.6 installed on CentOS 8

Post by jlehtone » 2020/10/14 07:42:10

Halverson44 wrote:
2020/10/14 06:50:46
How to get python 3.7.6 installed on CentOS 8
I have tried many ways of installing python3.7.6 on centos 7.
Which version of CentOS are you talking about?

Code: Select all

CentOS 8 $ sudo dnf module list | grep python
python27  2.7 [d]     common [d]           Python programming language, version 2.7
python36  3.6 [d][e]  build, common [d]    Python programming language, version 3.6
python38  3.8 [d]     build, common [d]    Python programming language, version 3.8

CentOS 8 $ sudo dnf list python2 python3[6-8]
python2.x86_64        2.7.17-1.module_el8.2.0+381+9a5b3c3b  AppStream
python36.x86_64       3.6.8-2.module_el8.1.0+245+c39af44f   AppStream
python38.x86_64       3.8.0-6.module_el8.2.0+317+61fa6e7d   AppStream
Ok, no 3.7 in plain sight. Are you sure that neither 3.6 nor 3.8 is compatible with your application?

Wrong CentOS?

Code: Select all

CentOS 7 $ sudo yum list python3 rh-python3[3-9]-python
python3.x86_64                  3.6.8-13.el7        @base
rh-python35-python.x86_64       3.5.1-13.el7        centos-sclo-rh    
rh-python36-python.x86_64       3.6.9-2.el7         centos-sclo-rh
rh-python38-python.x86_64       3.8.0-15.el7        centos-sclo-rh
EPEL for el7 has still python34 too.

Overall, 3.7 seems to have been skipped over.

Post Reply

Return to “CentOS 8 - General Support”