Page 1 of 2

CentOS8 Reboot Loop

Posted: 2020/09/26 14:33:53
by thomas.deans
I really do not know what has happened here but some help would be appreciated. Forgive me if this isnt the correct location but I couldn't figure out where this should go.

I have a centos7 box running nginx, apache, minidlna, rclone with gdrive backend, a non default mta sending from google and ssh(key based with google auth via MFA). I am building a clone of this box in Centos8, which will be deployed in a second location but only running minidlna, ssh and rclone to serve as a media server for that location and a duplicate local/tertiary backup of my media files.

The PC i'm installing Centos8 on is a Lenovo flat version, not the tiny series but the kind you would set an LCD on top of or beside with it sitting vertical. It has 3 SATA connectors on the motherboard but only one 320GB HDD and a DVD, no place to install a second 3.5" HDD.

I created a bootable USB with Full Centos8 install DVD (8 GB .ISO) and I followed the guide using a different installer than Unetbootin. I was successful in installing the basic Centos8 with GUI. I did all the regular setup and updated the system and have rebooted several times with no issues.

I spent about a week setting up SSH and getting 2 factor working with my existing keys, etc and had all working right. I installed minidlna with a test directory and had that serving on my LAN with no issues.

I added the rpmforge repo and did an update and that updated fine with no issues. I then yesterday powered off the system so that I could install a new 2TB 3.5" HDD that came in the mail to serve as the /Media drive for minidlna.

I stopped minidlna, unmounted the temp /Media, removed the /Media folder and powered it off. I opened the case, couldn't find a mounting location for the 3.5" drive so I decided that since i did not need the DVD drive I would just remove that and use the HDD in that location. Unfortunately I could only mount it with 1 screw but it was very sturdy so that's what I did. In the meantime i was going to order a 5.25 to 3.5 adapter bracket to fix properly until i ran into this reboot issue.

I put it all back together and booted up and it shows the grub menu with two kernel's and a third rescue line., no matter which i choose it scrolls text then shows the black screen with a spinning circle then shows a few lines of text at the top before rebooting and doing the same over and over until i push the power button.

I am able to hit e and add rd.break and go into single user mode without reboot and upon checking dmesg, journalctl there are tons of errors I did search some of them, giving a multitude of fixes some of which I have tried to no avail.

Assuming the issue was from removing the DVD drive I put it back as it was thinking after a reboot it would resolve the issue but unfortunately it is exhibiting the same behavior.

At this point I think I need some expert community help as I really don't want to have to start over. Although I now am a little more familiar and could probably get it back in a few days but don't want to do that and have to start over again if I don't have to!.

I did try changing the DVD drive in BIOS to last in the boot order and it did not show the second drive by name in BIOS. I also moved the SATA cable to the spare port on the motherboard and got the same result. I moved the SATA back and reinstalled the DVD drive and changed the boot order back and none of these resolved the boot issue. I have the new drive in an external dock on my Win 10 PC and crystaldisk reports no issues with the drive.

At Switch_root# prompt I did mount -o remount,rw /sysroot, then chroot /sysroot. At the new prompt, I am unable to get dmidecode info and I also cannot seem to run blkid lsblk, or fdisk -l to check fstab UUID. I have also tried systemctl disable chrony-wait.service(might be another name) which i read somewhere might cause the issue, but that did not resolve.

Any help with this issue would be greatly appreciated!

Re: CentOS8 Reboot Loop

Posted: 2020/09/26 15:03:01
by TrevorH
I added the rpmforge repo and did an update and that updated fine with no issues
That was a mistake. The rpmforge repo has been dead as a dodo for over 5 years and I do not believe they support el8 at all. Avoid it. I don't think it's the cause of your current problem but it's very much a repo to avoid.

For your other issue, reboot the system, edit the current kernel entry at the grub menu, remove the words 'rhgb' and 'quiet' from it and then boot up with that. It won't fix the problem but it will let you see the kernel messages as it boots. You should be able to use Shift-PgUp to scroll back up the kernel log as long as you do not switch virtual terminals before you try.

You need to tell us the exact errors you are getting or any help you get here will just be guesswork.

Re: CentOS8 Reboot Loop

Posted: 2020/09/26 15:39:17
by thomas.deans
I also did the rpmforge on my other box, really that was more for an updated version of FFMPEG and the most current minidlna which i don't believe is being updated but that package works for me. There was a section for el8 on rpmforge but i can remove that repo on my other system just to be safe.

I had done what you said and searched the errors but got nowhere, I will go do that again and note the errors. I was not aware of Shift+PgUp

Re: CentOS8 Reboot Loop

Posted: 2020/09/26 15:52:45
by TrevorH
I just looked and there is no rpmforge for el8. Are you sure you don't mean rpmfusion? They sound similar but one is maintained and the other is not. The rpmfusion repo is the recommended place for multimedia packages on 8 since there is no nux-dextop for it.

Re: CentOS8 Reboot Loop

Posted: 2020/09/26 22:13:07
by thomas.deans
EDIT, just saw your reply. Yes, I meant rpm fusion. I dropped nux on el7 and replaced with that.

Below is the info requested earlier, I was typing it up when my wife got home and we took the kids out and I just got home.

So, to be more specific I went into BIOS and noted the Hardware:

ThinkCentre M71e
Model: 3133A8U

I had a durr moment when i replied a few minutes ago, I cant use Shift+PgUp because when it gets to the last line it reboots on its own. I ended up having to record with my phone and go back and type it.

Boot Menu List:
Centos Linux (4.18.0-193.19.1.el8_2.x86_64) 8 (Core)
Centos Linux (4.18.0-193.14.2.el8_2.x86_64) 8 (Core)
Centos Linux (4.18.0-193.el8.x86_64) 8 (Core)
Centos Linux (0-rescue-1974db427c2249e18ad18f6e9d84fc68) 8 (Core)

Normal loop without editing grub the screen comes up with the spinner then it shows this text before rebooting:

watchdog: watchdog0: watchdog
alsactl daemon stopped
dracut killing all processes
system is rebooting

then editing grub removing rgbh quiet gives these errors:

[Failed] Failed to start Journal Service.
See 'systemctl ststus systemd-journald.service' for details.
[Failed] Failed to start Journal Service.
See 'systemctl ststus systemd-journald.service' for details.
[Failed] Failed to start Journal Service.
See 'systemctl ststus systemd-journald.service' for details.
[Failed] Failed to start Journal Service.
See 'systemctl ststus systemd-journald.service' for details.
[Failed] Failed to start remount root and kernel filesystems
[Failed] Failed to start load kernel modules.
[Failed] Failed to start apply kernel variables
[Failed] Failed to start journal service
[Depend] Dependency failed for Flush Journal to Persistent Storage.
[Failed] Failed to start load/save random seed
[Failed] Failed to start create static mode in /dev
dracut warning killing all remaining processes
xfs unmounting filesystem
dracut warning unmounted /oldroot
dracut disassembling device-mapper-devices

Re: CentOS8 Reboot Loop

Posted: 2020/09/26 22:57:05
by TrevorH
[Failed] Failed to start Journal Service.
I think it's likely there are other errors prior to those.

Re: CentOS8 Reboot Loop

Posted: 2020/09/26 23:43:42
by thomas.deans
Boot video boot line w/o rgbh quiet

Re: CentOS8 Reboot Loop

Posted: 2020/09/26 23:45:31
by TrevorH
Sorry, don't have a FB account and it wants me to login.

Re: CentOS8 Reboot Loop

Posted: 2020/09/26 23:57:29
by thomas.deans
I just updated my link above

Re: CentOS8 Reboot Loop

Posted: 2020/09/27 01:52:47
by TrevorH
Try the next kernel down on the grub menu. The first error in that says it's failed to start the Load Kernel Modules service so I am thinking that perhaps your initramfs file for the current kernel is broken.