centos stream kickstart fails with perl dependency

Issues related to applications and software problems and general support
Post Reply
adrian27
Posts: 9
Joined: 2020/02/06 12:04:15

centos stream kickstart fails with perl dependency

Post by adrian27 » 2020/07/31 08:09:55

Hello,

I am doing a minimal installation of CentOS Stream using a kickstart file. The installation fails with some perl dependency, something like module perl:5.26 conflicts with perl:5.30, see below.

Is there anything I need to add in kickstart to avoid such issue? This is working fine if I point the kickstart repo to a CentOS 8 mirror...

Code: Select all

[...]
Running pre-installation scripts
.
Discovering realm to join
.
Running pre-installation tasks
.....
Installing.
Starting package installation process

The installation was stopped due to an error which occurred while running in non-interactive cmdline mode. Since there cannot be any questions in cmdline mode, edit your kickstart file and retry installation.
The exact error message is:

Non interactive installation failed: Non interactive installation failed: Problems in request:
Modular dependency problems with Defaults:

 Problem 1: module perl-FCGI:0.78:8030020200618214557:2fbcbb20-0.x86_64 requires module(perl:5.30), but none of the providers can be installed
  - module perl:5.26:8000020190628020724:55190bc5-0.x86_64 conflicts with module(perl:5.30) provided by perl:5.30:8030020200715145239:568f3a16-0.x86_64
  - module perl:5.30:8030020200715145239:568f3a16-0.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:8000020190628020724:55190bc5-0.x86_64
  - conflicting requests
 Problem 2: module perl:5.26:8000020190628020724:55190bc5-0.x86_64 conflicts with module(perl:5.30) provided by perl:5.30:8030020200715145239:568f3a16-0.x86_64
  - module perl:5.30:8030020200715145239:568f3a16-0.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:8000020190628020724:55190bc5-0.x86_64
  - module perl-YAML:1.24:8030020200723225335:a6d43775-0.x86_64 requires module(perl:5.30), but none of the providers can be installed
  - module freeradius:3.0:8030020200724204325:1e4bbb35-0.x86_64 requires module(perl:5.26), but none of the providers can be installed
  - conflicting requests
 Problem 3: module perl-YAML:1.24:8030020200723225335:a6d43775-0.x86_64 requires module(perl:5.30), but none of the providers can be installed
  - module perl:5.26:8000020190628020724:55190bc5-0.x86_64 conflicts with module(perl:5.30) provided by perl:5.30:8030020200715145239:568f3a16-0.x86_64
  - module perl:5.30:8030020200715145239:568f3a16-0.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:8000020190628020724:55190bc5-0.x86_64
  - module perl-App-cpanminus:1.7044:8030020200723233049:09acf126-0.x86_64 requires module(perl-YAML), but none of the providers can be installed
  - module perl-App-cpanminus:1.7044:8030020200723233049:09acf126-0.x86_64 requires module(perl:5.26), but none of the providers can be installed
  - conflicting requests.

The installer will now terminate.

Mquadrat
Posts: 1
Joined: 2020/07/31 13:05:08

Re: centos stream kickstart fails with perl dependency

Post by Mquadrat » 2020/07/31 13:07:59

I get the same with dnf update:

Code: Select all

[root@www ~]# dnf update
Last metadata expiration check: 2:18:15 ago on Fri 31 Jul 2020 12:44:30 PM CEST.
Modular dependency problems:

 Problem 1: module perl-FCGI:0.78:8030020200618214557:2fbcbb20-0.x86_64 requires module(perl:5.30), but none of the providers can be installed
  - module perl:5.26:8000020190628020724:55190bc5-0.x86_64 conflicts with module(perl:5.30) provided by perl:5.30:8030020200715145239:568f3a16-0.x86_64
  - module perl:5.30:8030020200715145239:568f3a16-0.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:8000020190628020724:55190bc5-0.x86_64
  - conflicting requests
 Problem 2: module perl:5.26:8000020190628020724:55190bc5-0.x86_64 conflicts with module(perl:5.30) provided by perl:5.30:8030020200715145239:568f3a16-0.x86_64
  - module perl:5.30:8030020200715145239:568f3a16-0.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:8000020190628020724:55190bc5-0.x86_64
  - module perl-YAML:1.24:8030020200723225335:a6d43775-0.x86_64 requires module(perl:5.30), but none of the providers can be installed
  - module freeradius:3.0:8030020200724204325:1e4bbb35-0.x86_64 requires module(perl:5.26), but none of the providers can be installed
  - conflicting requests
 Problem 3: module perl-YAML:1.24:8030020200723225335:a6d43775-0.x86_64 requires module(perl:5.30), but none of the providers can be installed
  - module perl:5.26:8000020190628020724:55190bc5-0.x86_64 conflicts with module(perl:5.30) provided by perl:5.30:8030020200715145239:568f3a16-0.x86_64
  - module perl:5.30:8030020200715145239:568f3a16-0.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:8000020190628020724:55190bc5-0.x86_64
  - module perl-App-cpanminus:1.7044:8030020200723233049:09acf126-0.x86_64 requires module(perl-YAML), but none of the providers can be installed
  - module perl-App-cpanminus:1.7044:8030020200723233049:09acf126-0.x86_64 requires module(perl:5.26), but none of the providers can be installed
  - conflicting requests
Dependencies resolved.
Nothing to do.
Complete!
I think its more like a warning because all updates/upgrades ran fine.


Edit: https://bugs.centos.org/view.php?id=17628

adrian27
Posts: 9
Joined: 2020/02/06 12:04:15

Re: centos stream kickstart fails with perl dependency

Post by adrian27 » 2020/07/31 18:14:49

Mquadrat wrote:
2020/07/31 13:07:59
I think its more like a warning because all updates/upgrades ran fine.
If in shell with dnf is more like a warning, with anaconda the kickstart installation crashes... therefore as long as there is this issue, I cannot do unattended centos stream deployments

is there any way we can configure anaconda to ignore these?

Post Reply

Return to “CentOS 8 - General Support”