kickstart fails. reason is obscure.

Issues related to applications and software problems and general support
Post Reply
iwishitwouldwork
Posts: 76
Joined: 2014/02/08 14:56:39

kickstart fails. reason is obscure.

Post by iwishitwouldwork » 2020/07/31 02:19:02

Trying to kickstart CentOS 8. My kickstart server is working -- I kickstart a similar machine without incident.
It's an Intel NUC, and I have updated the BIOS to the latest and greatest.


Here's the error from anaconda.

Code: Select all

Starting installer, one moment...
terminal size detection failed, using default width
anaconda 29.19.2.17-1.el8 for CentOS Linux 8 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2 and in second TMUX pane (ctrl+b, then press 2)
 * if the graphical installation interface fails to start, try again with the
   inst.text bootoption to start text installation
 * when reporting a bug add logs from /tmp as separate text/plain attachments
Traceback (most recent call last):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/nm.py", line 130, in _get
_property
    prop = proxy.Get('(ss)', interface_name, prop)
  File "/usr/lib64/python3.6/site-packages/gi/overrides/Gio.py", line 204, in _
_call__
    None)
GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.UnknownM
ethod: No such interface 'org.freedesktop.DBus.Properties' on object at path /o
rg/freedesktop/NetworkManager/Devices/204 (19)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/sbin/anaconda", line 621, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/network.py", line 1528, i
n networkInitialize
    devnames = apply_kickstart(ksdata)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/network.py", line 1484, i
n apply_kickstart
    ifcfg_path = find_ifcfg_file_of_device(dev_name)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/network.py", line 1008, i
n find_ifcfg_file_of_device
    if devname not in nm.nm_devices():
  File "/usr/lib64/python3.6/site-packages/pyanaconda/nm.py", line 196, in nm_d
evices
    iface = _get_property(device, "Interface", ".Device")
  File "/usr/lib64/python3.6/site-packages/pyanaconda/nm.py", line 136, in _get
_property
    raise UnknownMethodGetError
pyanaconda.nm.UnknownMethodGetError: UnknownMethodGetError()
Now, I've tried this a number of times and the above is the latest message but the message is not consistent. I didn't know how to save the anaconda msgs and I was loathe to simply re-type them so I did

Code: Select all

Alt-F2
cd /tmp
mkdir /tmp/uuu
mount /dev/sdb1 /tmp/uuu
/sbin/anaconda > /tmp/uuu/anaproper.msgs
tar cf /tmp/uuu/all.tar *log
As you can see, running anaconda the 2nd time concatenated the logs onto the first time. There were two empty log files, packaging.log and sensitive-info.log. syslog was too long to attach.

So, I'm completely at sea. As I said, the kickstart server should be fine. I've changed/simplified the kickstart configuration file a bunch. Any ideas?
Attachments
ifcfg.log
(4.65 KiB) Downloaded 12 times
dbus.log
(6.8 KiB) Downloaded 13 times
anaconda.log
(4.04 KiB) Downloaded 10 times

Fedora
Posts: 2
Joined: 2020/10/01 03:12:43

Re: kickstart fails. reason is obscure.

Post by Fedora » 2020/10/01 03:19:24

+1

Hi, any help is appreciated.

Fedora 32 installs fine, however get the same error with CentOS 8.2.2004 ISO (with "minimal" and "dvd1" ISOs).

Cheers and thank you in advance. :)

luupphar
Posts: 2
Joined: 2020/10/07 09:31:04

Re: kickstart fails. reason is obscure.

Post by luupphar » 2020/10/07 09:43:25

Could it be the related that authconfig is deprecated. I can not install CentOS-8.2.2004-x86_64-minimal.iso 08-Jun-2020 22:09 on VMware Fusion 12.0. Similar (not same) issue raises from Acnaconda / Kickstart/ kickstart.py

1. From: https://bugzilla.redhat.com/show_bug.cgi?id=1542968

2. From: https://access.redhat.com/documentation ... -en-US.pdf
5.7.1. auth or authconfig is deprecated in RHEL 8
The auth or authconfig Kickstart command is deprecated in Red Hat Enterprise Linux 8 because the
authconfig tool and package have been removed.
Similarly to authconfig commands issued on command line, authconfig commands in Kickstart scripts
now use the authselect-compat tool to run the new authselect tool. For a description of this
compatibility layer and its known issues, see the manual page authselect-migration(7). The installation
program will automatically detect use of the deprecated commands and install on the system the
authselect-compat package to provide the compatibility layer.

3.From: https://access.redhat.com/documentation ... own-issues
"11.1. Installer and image creation
The auth and authconfig Kickstart commands require the AppStream repository

The authselect-compat package is required by the auth and authconfig Kickstart commands during installation. Without this package, the installation fails if auth or authconfig are used. However, by design, the authselect-compat package is only available in the AppStream repository.

To work around this problem, verify that the BaseOS and AppStream repositories are available to the installer or use the authselect Kickstart command during installation.

(BZ#1640697)"

User avatar
TrevorH
Forum Moderator
Posts: 29915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: kickstart fails. reason is obscure.

Post by TrevorH » 2020/10/07 09:51:58

I'd suggest retrying with the full DVD iso not the minimal one. There have been a few problems reported with the minimal iso and I am not 100% sure that it is correct.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 8 - General Support”