Page 1 of 1

Centos 8 not booting from HDD

Posted: 2020/06/21 07:38:10
by joe@tabone.com
New installation on a new laptop, centos 8 installs fully and correctly but on restart it does not boot, as if the booting system is not installed
This is an i7-10 CPU laptop, on older CPUs Centos8 installs without any problems

I downloaded the CentOS Linux DVD ISO and tried two sites:
http://centos.mirror.garr.it/centos/8.2 ... 4-dvd1.iso
http://mirrors.ircam.fr/pub/CentOS/8.2. ... 4-dvd1.iso
then i did a usb using RaWrite rw32-setup-1.0.8.0 and booted good from usb
tried also balenaEtcher-Setup-1.5.99 ( tried three times) and also boots good from usb
(in the past I used Universal-USB-Installer-1.9.9.0 but with centos8 it did not work)

The installation starts correctly i am able to set the partitions, time, network config etc, no errors, the installation goes smoothly, then i am asked to reboot, I remove the pendrive, and the hdd does not boot. laptops has primary ssd and a secondard hdd, tried to install on both drives, with the same result

Re: Centos 8 not booting from HDD

Posted: 2020/06/21 17:05:51
by joe@tabone.com
this seems to be the issue:

https://support.sgo.es/support/solution ... changes%20(for%20example%20when

Re: Centos 8 not booting from HDD

Posted: 2020/06/21 20:32:12
by lightman47
My 2 cents -

My experience in previous versions has been that the appearance of the [REBOOT] button is misleading - people prematurely remove the installation media before the "finals" of the installation (after you click it) are complete.
- just my opinion

Re: Centos 8 not booting from HDD

Posted: 2020/06/23 15:41:16
by joe@tabone.com
tks for your note, we managed to do a boot USB drive which asks from which hdd we need to boot, if we choose the linux hdd it boots correctly, then the process has to be repeated if the laptop restarts. It is some UEFI compatibility with new hardware, or a combination of Centos/firmware. But then all Windows versions 8, 8.1, 10, 10 newest, all boot without any issues.

Re: Centos 8 not booting from HDD

Posted: 2020/06/26 13:40:14
by joe@tabone.com
lightman47 wrote:
2020/06/21 20:32:12
My 2 cents -

My experience in previous versions has been that the appearance of the [REBOOT] button is misleading - people prematurely remove the installation media before the "finals" of the installation (after you click it) are complete.
- just my opinion
yes, you are right, waiting for next reboot, and only remove the USB on the 2nd reboot seems to solve the issue. thanks for your note.

Re: Centos 8 not booting from HDD

Posted: 2020/06/26 14:01:15
by lightman47
This is also an issue in CentOS 7. I don't know why it can't be mentioned on that screen that the media should not yet be removed. I believe that period is when the actual boot information gets written to the drive.