Error to update xrdp

Issues related to applications and software problems and general support
Post Reply
omaggi
Posts: 2
Joined: 2020/06/05 12:10:10

Error to update xrdp

Post by omaggi » 2020/06/05 12:30:29

Hi :)
I have installed the xrdp package and it works fine, but now when I try to update, I have an Error:

***********
Error:
Problem 1: cannot install the best update candidate for package xrdp-selinux-1:0.9.13-1.el8.x86_64
- nothing provides selinux-policy >= 3.14.3-41.el8_2.2 needed by xrdp-selinux-1:0.9.13-2.el8.x86_64
Problem 2: package xrdp-selinux-1:0.9.13-1.el8.x86_64 requires xrdp = 1:0.9.13-1.el8, but none of the providers can be installed
- cannot install both xrdp-selinux-1:0.9.13-2.el8.x86_64 andxrdp-selinux-1:0.9.13-1.el8.x86_64
- problem with installed package xrdp-selinux-1:0.9.13-1.el8.x86_64
- cannot install the best update candidate for package xrdp-selinux-1:0.9.13-1.el8.x86_64
- nothing provides selinux-policy >= 3.14.3-41.el8_2.2 needed by xrdp-selinux-1:0.9.13-2.el8.x86_64
***********
Anybody can help me? Thx in advance :)

scottro
Forum Moderator
Posts: 2456
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: Error to update xrdp

Post by scottro » 2020/06/05 13:41:53

viewtopic.php?f=54&t=74589 talks about the same problem. It seems they uninstalled, then updated, but not sure if they reinstalled xrdp afterwards. But from experience with similar problems, usually after an update, you can reinstall the offending package.
New users should check the FAQ and Read Me First pages

Cris973
Posts: 1
Joined: 2020/06/05 15:13:55

Re: Error to update xrdp

Post by Cris973 » 2020/06/05 15:20:49

Hi, Exactly same problem here and it is not an update , i just can't install it for the first time.
tried to remove selinux-policies as well , but when i reinstall it and try to install xrdp-selinux again , same probleme.
Doesn't look related to viewtopic.php?f=54&t=74589 .

Will be happy to have solution too , big problem for me !

User avatar
TrevorH
Forum Moderator
Posts: 29069
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error to update xrdp

Post by TrevorH » 2020/06/05 15:49:21

This is almost certainly due to the release of RHEL 8.2 which updated a lot of packages. EPEL builds against RHEL not against CentOS so this package has been rebuilt for 8.2 but there is no CentOS 8.2 as yet. You'll need to use the EPEL archive to find the older version that was applicable for 8.1 and install that manually until such time as CentOS 8.2 is released.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

omaggi
Posts: 2
Joined: 2020/06/05 12:10:10

Re: Error to update xrdp

Post by omaggi » 2020/07/13 08:11:08

Hi to all of you and thx for the messages.

The new package of xrdp it was added to the centos 8.2 and now it's possible to update all the packages without any errors.

Thx a lot and stay safe.

Greetings omaggi :)

Post Reply

Return to “CentOS 8 - General Support”