[SOLVED] Installing CentOS on a MacBook Pro: "Error checking storage configuration"

Issues related to applications and software problems and general support
Post Reply
User avatar
Posts: 43
Joined: 2020/05/29 15:01:00

[SOLVED] Installing CentOS on a MacBook Pro: "Error checking storage configuration"

Post by oceanjeremy » 2020/06/04 00:07:11

Background: I've got a CentOS 8 VPS deployed and I'm running a LAMP server on it with ftp, phpMyAdmin, etc. Super happy with it. I have a CentOS 8 VirtualBox machine running on my year-old MacBook. I'm taking an online RHEL class, and loving it.

At this point I'd like to get the virtual machine off my brand year-old MacBook and just install the real deal on an older machine. Here are the details for that machine:
  • MacBook Pro, 15-inch, 2.53GHz, Mid 2009
  • Intel Core 2 Duo (so... 64 bit)
  • 4GB 1067 MHz DDR3 Memory
I know there is a lot of info online about installing any variation of Linux distribution on old MacBooks, but everything I've found is the recipe for partitioning and dual-booting it.

I don't want to dual-boot it.

I want to clobber OS X and run nothing but CentOS 8.

I've already got my ISO written over my USB stick via dd (as described here: https://wiki.centos.org/HowTos/InstallFromUSBkey).

All I need is a dumbed-down "how to" as to getting the old MacBook to recognize the USB and boot from it. I have some experience trying to do this from Open Firmware on another, older machine (never successfully, btw) — is that the direction I need to go? Or is there a quicker / less-involved way to do it?

Do I need to do anything to overwrite the old operating system, or will it do that on its own?
Last edited by oceanjeremy on 2020/06/06 03:02:49, edited 1 time in total.
Please be kind! I've only been a Linux user for two months.

User avatar
Posts: 43
Joined: 2020/05/29 15:01:00

Re: Installing CentOS 8 on a MacBook Pro

Post by oceanjeremy » 2020/06/06 03:02:13

I got it working! Posting my solution here in case anyone else encounters the same problem.

So the ISO/USB worked exactly as planned! Just booted up with the Option button held down, the USB showed up, the install GUI popped up, and I thought I was good to go.

Small hiccup: when I go to Network & Host Name I get "No network devices available." A little bit of Googling tells me I'll need to get drivers after the installation. Shouldn't be a problem — I can transfer them via USB, and hopefully I can get both my ethernet and wi-fi working. Either way I'll worry about that later. (What's the worst that can happen, I can just never use this machine again?)

Big hiccup: I go to Installation Destination and select my drive with "Automatic" for Storage Configuration. Follow a trail of errors and I finally find one that says, "resource to create this format macefi is unavailable." With Google as my friend I found this: https://bugzilla.redhat.com/show_bug.cgi?id=1751311#c16 ... Looks like RHEL stopped shipping the ISO with tools to automate an install onto Mac hardware. That's cool: I think Apple is evil too.

At this point I'd like to point out that I have absolutely no idea what I'm doing. I've never manually partitioned a drive, and this is the first time I've tried to install Linux on a physical machine.

So I followed the directions in that above link, except I had it automatically make mount points for me to start from (since I had no idea how to manually add the mount points). Then I did run into a problem with the step CentOS 8: create /boot/efi mountpoint, 600M, Standard EFI partition: when I try to add that mount point it gives me a red error on the bottom that says, "Failed to add new device. Click for details." Clicking for details brings up a completely blank dialogue box. Not... encouraging.

So what I did was take the automatically generated /boot mount point, then go and edit it to boot/efi with Standard Partition and EFI System Partition. Then I just added another /boot mount point with the same configuration as the automatically generated one.

Otherwise it behaved exactly as the described in the link above (including the mactel package error).

On reboot it went to the grub> prompt, just as described in the link above. So I followed the instructions in that link above: I rebooted to the ISO on the USB stick, selected Troubleshooting, selected Rescue a CentOS system. I chose 1 to boot to mnt/sysimage, did the chroot /mnt/sysimage.

The only thing different on the next step is instead of running grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg as it says, I ran grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg (because, duh, I'm installing CentOS not RHEL).

I did get the error those instructions described (device-mapper: reload ioctl on osprober-linux-sdc2 failed: Device or resource busy Command failed.) but I also got about fifteen lines of another error: /dev/sdb: open failed: No medium found. With Google by my side I determined this was probably some kind of hardware mapping issue that won't affect my booting, and is definitely something I can fix later. So I ignored it for now.

Then I rebooted, it did all the SELinux relabeling, rebooted again and voilà — my old MacBook is now a CentOS machine!

Now I just need to see if I can get drivers for my Wi-Fi and ethernet so I can actually connect to the internet, but that's for another day.
Please be kind! I've only been a Linux user for two months.

Forum Moderator
Posts: 2463
Joined: 2007/09/03 21:18:09
Location: NYC

Re: [SOLVED] Installing CentOS on a MacBook Pro: "Error checking storage configuration"

Post by scottro » 2020/06/06 13:16:02

Thanks for coming back and sharing your solution. No doubt it will help others in the future.
New users should check the FAQ and Read Me First pages

Posts: 1
Joined: 2020/11/20 14:13:04

Re: [SOLVED] Installing CentOS on a MacBook Pro: "Error checking storage configuration"

Post by psnellin » 2020/11/20 14:16:14

Thank you for this! it helped me get Oracle Linux 8 onto a mid 2010 macbook.

Post Reply

Return to “CentOS 8 - General Support”