"cannot install best candidate ...."

Issues related to applications and software problems and general support
Post Reply
mjz
Posts: 65
Joined: 2020/02/13 22:05:02

"cannot install best candidate ...."

Post by mjz » 2020/05/30 18:30:46

I tried to "dnf update" and received the following error for the first time:

Error:
Problem 1: cannot install the best update candidate for package xrdp-selinux-1:0.9.13-1.el8.x86_64
- nothing provides selinux-policy >= 3.14.3-41.el8_2.2 needed by xrdp-selinux-1:0.9.13-2.el8.x86_64
Problem 2: package xrdp-selinux-1:0.9.13-1.el8.x86_64 requires xrdp = 1:0.9.13-1.el8,
but none of the providers can be installed
- cannot install both xrdp-1:0.9.13-2.el8.x86_64 and xrdp-1:0.9.13-1.el8.x86_64
- problem with installed package xrdp-selinux-1:0.9.13-1.el8.x86_64
- cannot install the best update candidate for package xrdp-1:0.9.13-1.el8.x86_64
- nothing provides selinux-policy >= 3.14.3-41.el8_2.2 needed by xrdp-selinux-1:0.9.13-2.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages
or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Suggestions on what I can do - if anything?

GeraldScott
Posts: 1
Joined: 2020/05/31 12:00:31

Re: "cannot install best candidate ...."

Post by GeraldScott » 2020/05/31 12:06:28

My workaround was to remove the xrdp package (and hence the offending dependency), and then perform the update.

mjz
Posts: 65
Joined: 2020/02/13 22:05:02

Re: "cannot install best candidate ...."

Post by mjz » 2020/06/04 19:48:10

... and then reinstall xrdp? I would hate to lose xrdp because that is how I connect with the Centos 8 server

Post Reply

Return to “CentOS 8 - General Support”