Page 1 of 1

[SOLVED] CentOS 8.1.1911: Can't install "nagios-plugins-all-2.3.3-1.el8.x86_64" due to missing PERL dependencies

Posted: 2020/05/19 12:01:00
by ddjm73
Hi all,

we use Ansible to manage and configure our many CentOS 7.x and 8.x installations and everything was working fine so far. But now with freshly installed CentOS 8.1 installations I am running into this error when I run my Ansible playbook against them:

Image

This was working before! :?

The relevant section in the Ansible playbook looks like this:

Image

I tried to solve the problem by installing the packages manually but that failed too (please see the output below). The core of the problem seems to be that there is no "perl-Convert-ASN1" package which is a dependency for "perl-Crypt-X509", which is a dependency for "nagios-plugins-ssl_validity", which is a dependency for "nagios-plugins-all" ... so how do I get out of this dependency hell?

Output from manual installation attempts:

Code: Select all

yum --enablerepo=epel,epel-testing,PowerTools install perl-utf8-all  perl-Import-Into perl-PerlIO-utf8_strict nagios-plugins-all nagios-plugins-ssl_validity perl-Crypt-X509

Last metadata expiration check: 0:19:49 ago on Tue 19 May 2020 01:35:08 PM CEST.
Package perl-utf8-all-0.024-7.el8.noarch is already installed.
Package perl-Import-Into-1.002005-7.el8.noarch is already installed.
Package perl-PerlIO-utf8_strict-0.007-5.el8.x86_64 is already installed.
Error:
 Problem 1: conflicting requests
  - nothing provides perl(Convert::ASN1) >= 0.19 needed by perl-Crypt-X509-0.51-19.el8.noarch
 Problem 2: package nagios-plugins-ssl_validity-2.3.3-1.el8.x86_64 requires perl(Crypt::X509), but none of the providers can be installed
  - conflicting requests
  - nothing provides perl(Convert::ASN1) >= 0.19 needed by perl-Crypt-X509-0.51-19.el8.noarch
 Problem 3: package nagios-plugins-all-2.3.3-1.el8.x86_64 requires nagios-plugins-ssl_validity, but none of the providers can be installed
  - package nagios-plugins-ssl_validity-2.3.3-1.el8.x86_64 requires perl(Crypt::X509), but none of the providers can be installed
  - conflicting requests
  - nothing provides perl(Convert::ASN1) >= 0.19 needed by perl-Crypt-X509-0.51-19.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
A package "perl-Convert-ASN1" exists for CentOS 7.x, e.g. here:
https://centos.pkgs.org/7/centos-x86_64 ... h.rpm.html

... but I can't find one for CentOS 8.x

So how can I solve this problem?

Re: CentOS 8.1.1911: Can't install "nagios-plugins-all-2.3.3-1.el8.x86_64" due to missing PERL dependencies

Posted: 2020/05/19 12:19:45
by TrevorH
I'd suggest reporting it to EPEL on bugzilla.redhat.com. The package that is complaining about the lack of perl-convert-ASN1 is from EPEL, the package perl-convert-ASN1 is from EPEL...

Re: CentOS 8.1.1911: Can't install "nagios-plugins-all-2.3.3-1.el8.x86_64" due to missing PERL dependencies

Posted: 2020/05/19 12:22:55
by ddjm73
Thanks for approving the post and for your answer...

Something else... why are my "img" tags above not working correctly? :?: Instead of showing the image inline they are only shown below in the "attachments" section?

Re: CentOS 8.1.1911: Can't install "nagios-plugins-all-2.3.3-1.el8.x86_64" due to missing PERL dependencies

Posted: 2020/05/20 10:36:58
by ddjm73
In case anyone runs into the same problem and maybe finds this post via e.g. Google ...

Please check these bug reports if there is a solution to the problem that I posted about above:

https://bugzilla.redhat.com/show_bug.cgi?id=1837397
https://pagure.io/fedora-infrastructure/issue/8928

Re: [SOLVED] CentOS 8.1.1911: Can't install "nagios-plugins-all-2.3.3-1.el8.x86_64" due to missing PERL dependencies

Posted: 2020/06/08 06:37:39
by ddjm73
Solution, as of June 2020:

Code: Select all

dnf --enablerepo=epel-testing,PowerTools update
=> This will download the updated "nagios-plugins-all" package without the broken dependencies.