Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Issues related to applications and software problems and general support
Post Reply
mprater
Posts: 20
Joined: 2020/04/16 19:10:33

Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by mprater » 2020/04/16 19:41:40

Hi All,

I updated my CentOS 8 machine yesterday:

Code: Select all

sudo yum update
. This updated the kernel from

kernel-4.18.0-147.5.1.el8_1.x86_64 to kernel-4.18.0-147.8.1.el8_1.x86_64

along with:

Code: Select all

puter:~:{12:17:04}sudo yum history info 44
Transaction ID : 44
Begin time     : Wed 15 Apr 2020 06:23:04 PM PDT
Begin rpmdb    : 1839:1df568feab4f9c5d6c3564553d153f5bec6ede7a
End time       : Wed 15 Apr 2020 06:28:23 PM PDT (5 minutes)
End rpmdb      : 1843:b6fbd743587afbeef1e850e03bbaea8b419b0f19
User           : Mitch Prater <mprater>
Return-Code    : Success
Releasever     : 8
Command Line   : update
Packages Altered:
    Install  kernel-4.18.0-147.8.1.el8_1.x86_64                                                  @BaseOS
    Install  kernel-core-4.18.0-147.8.1.el8_1.x86_64                                             @BaseOS
    Install  kernel-devel-4.18.0-147.8.1.el8_1.x86_64                                            @BaseOS
    Install  kernel-modules-4.18.0-147.8.1.el8_1.x86_64                                          @BaseOS
    Upgrade  buildah-1.11.6-6.module_el8.1.0+298+41f9343a.x86_64                                 @AppStream
    Upgraded buildah-1.11.6-4.module_el8.1.0+272+3e64ee36.x86_64                                 @@System
    Upgrade  conmon-2:2.0.6-1.module_el8.1.0+298+41f9343a.x86_64                                 @AppStream
    Upgraded conmon-2:2.0.6-1.module_el8.1.0+272+3e64ee36.x86_64                                 @@System
    Upgrade  container-selinux-2:2.124.0-1.module_el8.1.0+298+41f9343a.noarch                    @AppStream
    Upgraded container-selinux-2:2.124.0-1.module_el8.1.0+272+3e64ee36.noarch                    @@System
    Upgrade  containernetworking-plugins-0.8.3-4.module_el8.1.0+298+41f9343a.x86_64              @AppStream
    Upgraded containernetworking-plugins-0.8.3-4.module_el8.1.0+272+3e64ee36.x86_64              @@System
    Upgrade  containers-common-1:0.1.40-8.module_el8.1.0+298+41f9343a.x86_64                     @AppStream
    Upgraded containers-common-1:0.1.40-8.module_el8.1.0+275+1b647963.x86_64                     @@System
    Upgrade  firefox-68.7.0-2.el8_1.x86_64                                                       @AppStream
    Upgraded firefox-68.6.0-1.el8_1.x86_64                                                       @@System
    Upgrade  flatpak-1.0.9-2.el8_1.x86_64                                                        @AppStream
    Upgraded flatpak-1.0.9-1.el8_1.x86_64                                                        @@System
    Upgrade  flatpak-libs-1.0.9-2.el8_1.x86_64                                                   @AppStream
    Upgraded flatpak-libs-1.0.9-1.el8_1.x86_64                                                   @@System
    Upgrade  fuse-overlayfs-0.7.2-5.module_el8.1.0+298+41f9343a.x86_64                           @AppStream
    Upgraded fuse-overlayfs-0.7.2-1.module_el8.1.0+272+3e64ee36.x86_64                           @@System
    Upgrade  libluksmeta-9-3.el8_1.1.x86_64                                                      @AppStream
    Upgraded libluksmeta-9-2.el8.x86_64                                                          @@System
    Upgrade  libvirt-daemon-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64                        @AppStream
    Upgraded libvirt-daemon-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64                        @@System
    Upgrade  libvirt-daemon-config-network-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64         @AppStream
    Upgraded libvirt-daemon-config-network-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64         @@System
    Upgrade  libvirt-daemon-driver-interface-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64       @AppStream
    Upgraded libvirt-daemon-driver-interface-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64       @@System
    Upgrade  libvirt-daemon-driver-network-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64         @AppStream
    Upgraded libvirt-daemon-driver-network-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64         @@System
    Upgrade  libvirt-daemon-driver-nodedev-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64         @AppStream
    Upgraded libvirt-daemon-driver-nodedev-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64         @@System
    Upgrade  libvirt-daemon-driver-nwfilter-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64        @AppStream
    Upgraded libvirt-daemon-driver-nwfilter-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64        @@System
    Upgrade  libvirt-daemon-driver-qemu-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64            @AppStream
    Upgraded libvirt-daemon-driver-qemu-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64            @@System
    Upgrade  libvirt-daemon-driver-secret-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64          @AppStream
    Upgraded libvirt-daemon-driver-secret-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64          @@System
    Upgrade  libvirt-daemon-driver-storage-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64         @AppStream
    Upgraded libvirt-daemon-driver-storage-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64         @@System
    Upgrade  libvirt-daemon-driver-storage-core-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64    @AppStream
    Upgraded libvirt-daemon-driver-storage-core-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64    @@System
    Upgrade  libvirt-daemon-driver-storage-disk-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64    @AppStream
    Upgraded libvirt-daemon-driver-storage-disk-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64    @@System
    Upgrade  libvirt-daemon-driver-storage-gluster-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64 @AppStream
    Upgraded libvirt-daemon-driver-storage-gluster-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64 @@System
    Upgrade  libvirt-daemon-driver-storage-iscsi-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64   @AppStream
    Upgraded libvirt-daemon-driver-storage-iscsi-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64   @@System
    Upgrade  libvirt-daemon-driver-storage-logical-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64 @AppStream
    Upgraded libvirt-daemon-driver-storage-logical-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64 @@System
    Upgrade  libvirt-daemon-driver-storage-mpath-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64   @AppStream
    Upgraded libvirt-daemon-driver-storage-mpath-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64   @@System
    Upgrade  libvirt-daemon-driver-storage-rbd-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64     @AppStream
    Upgraded libvirt-daemon-driver-storage-rbd-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64     @@System
    Upgrade  libvirt-daemon-driver-storage-scsi-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64    @AppStream
    Upgraded libvirt-daemon-driver-storage-scsi-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64    @@System
    Upgrade  libvirt-daemon-kvm-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64                    @AppStream
    Upgraded libvirt-daemon-kvm-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64                    @@System
    Upgrade  libvirt-libs-4.5.0-35.3.module_el8.1.0+297+df420408.x86_64                          @AppStream
    Upgraded libvirt-libs-4.5.0-35.2.module_el8.1.0+266+ba744077.x86_64                          @@System
    Upgrade  luksmeta-9-3.el8_1.1.x86_64                                                         @AppStream
    Upgraded luksmeta-9-2.el8.x86_64                                                             @@System
    Upgrade  mutter-3.32.2-12.el8_1.x86_64                                                       @AppStream
    Upgraded mutter-3.32.2-11.el8_1.x86_64                                                       @@System
    Upgrade  podman-1.6.4-4.module_el8.1.0+298+41f9343a.x86_64                                   @AppStream
    Upgraded podman-1.6.4-2.module_el8.1.0+272+3e64ee36.x86_64                                   @@System
    Upgrade  podman-manpages-1.6.4-4.module_el8.1.0+298+41f9343a.noarch                          @AppStream
    Upgraded podman-manpages-1.6.4-2.module_el8.1.0+272+3e64ee36.noarch                          @@System
    Upgrade  qemu-guest-agent-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64                  @AppStream
    Upgraded qemu-guest-agent-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64                  @@System
    Upgrade  qemu-img-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64                          @AppStream
    Upgraded qemu-img-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64                          @@System
    Upgrade  qemu-kvm-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64                          @AppStream
    Upgraded qemu-kvm-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64                          @@System
    Upgrade  qemu-kvm-block-curl-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64               @AppStream
    Upgraded qemu-kvm-block-curl-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64               @@System
    Upgrade  qemu-kvm-block-gluster-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64            @AppStream
    Upgraded qemu-kvm-block-gluster-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64            @@System
    Upgrade  qemu-kvm-block-iscsi-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64              @AppStream
    Upgraded qemu-kvm-block-iscsi-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64              @@System
    Upgrade  qemu-kvm-block-rbd-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64                @AppStream
    Upgraded qemu-kvm-block-rbd-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64                @@System
    Upgrade  qemu-kvm-block-ssh-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64                @AppStream
    Upgraded qemu-kvm-block-ssh-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64                @@System
    Upgrade  qemu-kvm-common-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64                   @AppStream
    Upgraded qemu-kvm-common-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64                   @@System
    Upgrade  qemu-kvm-core-15:2.12.0-88.module_el8.1.0+297+df420408.3.x86_64                     @AppStream
    Upgraded qemu-kvm-core-15:2.12.0-88.module_el8.1.0+266+ba744077.2.x86_64                     @@System
    Upgrade  rpm-build-4.14.2-26.el8_1.x86_64                                                    @AppStream
    Upgraded rpm-build-4.14.2-25.el8.x86_64                                                      @@System
    Upgrade  runc-1.0.0-64.rc9.module_el8.1.0+298+41f9343a.x86_64                                @AppStream
    Upgraded runc-1.0.0-64.rc9.module_el8.1.0+272+3e64ee36.x86_64                                @@System
    Upgrade  slirp4netns-0.4.2-3.git21fdece.module_el8.1.0+298+41f9343a.x86_64                   @AppStream
    Upgraded slirp4netns-0.4.2-2.git21fdece.module_el8.1.0+272+3e64ee36.x86_64                   @@System
    Upgrade  telnet-1:0.17-73.el8_1.1.x86_64                                                     @AppStream
    Upgraded telnet-1:0.17-73.el8.x86_64                                                         @@System
    Upgrade  augeas-libs-1.12.0-2.el8_1.1.x86_64                                                 @BaseOS
    Upgraded augeas-libs-1.12.0-2.el8.x86_64                                                     @@System
    Upgrade  binutils-2.30-58.el8_1.2.x86_64                                                     @BaseOS
    Upgraded binutils-2.30-58.el8_1.1.x86_64                                                     @@System
    Upgrade  bpftool-4.18.0-147.8.1.el8_1.x86_64                                                 @BaseOS
    Upgraded bpftool-4.18.0-147.5.1.el8_1.x86_64                                                 @@System
    Upgrade  coreutils-8.30-6.el8_1.1.x86_64                                                     @BaseOS
    Upgraded coreutils-8.30-6.el8.x86_64                                                         @@System
    Upgrade  coreutils-common-8.30-6.el8_1.1.x86_64                                              @BaseOS
    Upgraded coreutils-common-8.30-6.el8.x86_64                                                  @@System
    Upgrade  firewalld-0.7.0-5.el8_1.1.noarch                                                    @BaseOS
    Upgraded firewalld-0.7.0-5.el8.noarch                                                        @@System
    Upgrade  firewalld-filesystem-0.7.0-5.el8_1.1.noarch                                         @BaseOS
    Upgraded firewalld-filesystem-0.7.0-5.el8.noarch                                             @@System
    Upgrade  kernel-headers-4.18.0-147.8.1.el8_1.x86_64                                          @BaseOS
    Upgraded kernel-headers-4.18.0-147.5.1.el8_1.x86_64                                          @@System
    Upgrade  kernel-tools-4.18.0-147.8.1.el8_1.x86_64                                            @BaseOS
    Upgraded kernel-tools-4.18.0-147.5.1.el8_1.x86_64                                            @@System
    Upgrade  kernel-tools-libs-4.18.0-147.8.1.el8_1.x86_64                                       @BaseOS
    Upgraded kernel-tools-libs-4.18.0-147.5.1.el8_1.x86_64                                       @@System
    Upgrade  kexec-tools-2.0.19-12.el8_1.2.x86_64                                                @BaseOS
    Upgraded kexec-tools-2.0.19-12.el8_1.1.x86_64                                                @@System
    Upgrade  kmod-kvdo-6.2.1.138-58.el8_1.x86_64                                                 @BaseOS
    Upgraded kmod-kvdo-6.2.1.138-57.el8.x86_64                                                   @@System
    Upgrade  libipa_hbac-2.2.0-19.el8_1.1.x86_64                                                 @BaseOS
    Upgraded libipa_hbac-2.2.0-19.el8.x86_64                                                     @@System
    Upgrade  libsss_autofs-2.2.0-19.el8_1.1.x86_64                                               @BaseOS
    Upgraded libsss_autofs-2.2.0-19.el8.x86_64                                                   @@System
    Upgrade  libsss_certmap-2.2.0-19.el8_1.1.x86_64                                              @BaseOS
    Upgraded libsss_certmap-2.2.0-19.el8.x86_64                                                  @@System
    Upgrade  libsss_idmap-2.2.0-19.el8_1.1.x86_64                                                @BaseOS
    Upgraded libsss_idmap-2.2.0-19.el8.x86_64                                                    @@System
    Upgrade  libsss_nss_idmap-2.2.0-19.el8_1.1.x86_64                                            @BaseOS
    Upgraded libsss_nss_idmap-2.2.0-19.el8.x86_64                                                @@System
    Upgrade  libsss_sudo-2.2.0-19.el8_1.1.x86_64                                                 @BaseOS
    Upgraded libsss_sudo-2.2.0-19.el8.x86_64                                                     @@System
    Upgrade  net-snmp-libs-1:5.8-12.el8_1.1.x86_64                                               @BaseOS
    Upgraded net-snmp-libs-1:5.8-12.el8_1.x86_64                                                 @@System
    Upgrade  nftables-1:0.9.0-14.el8_1.1.x86_64                                                  @BaseOS
    Upgraded nftables-1:0.9.0-14.el8.x86_64                                                      @@System
    Upgrade  openssl-1:1.1.1c-2.el8_1.1.x86_64                                                   @BaseOS
    Upgraded openssl-1:1.1.1c-2.el8.x86_64                                                       @@System
    Upgrade  openssl-devel-1:1.1.1c-2.el8_1.1.x86_64                                             @BaseOS
    Upgraded openssl-devel-1:1.1.1c-2.el8.x86_64                                                 @@System
    Upgrade  openssl-libs-1:1.1.1c-2.el8_1.1.x86_64                                              @BaseOS
    Upgraded openssl-libs-1:1.1.1c-2.el8.x86_64                                                  @@System
    Upgrade  python3-firewall-0.7.0-5.el8_1.1.noarch                                             @BaseOS
    Upgraded python3-firewall-0.7.0-5.el8.noarch                                                 @@System
    Upgrade  python3-perf-4.18.0-147.8.1.el8_1.x86_64                                            @BaseOS
    Upgraded python3-perf-4.18.0-147.5.1.el8_1.x86_64                                            @@System
    Upgrade  python3-rpm-4.14.2-26.el8_1.x86_64                                                  @BaseOS
    Upgraded python3-rpm-4.14.2-25.el8.x86_64                                                    @@System
    Upgrade  python3-sssdconfig-2.2.0-19.el8_1.1.noarch                                          @BaseOS
    Upgraded python3-sssdconfig-2.2.0-19.el8.noarch                                              @@System
    Upgrade  rpm-4.14.2-26.el8_1.x86_64                                                          @BaseOS
    Upgraded rpm-4.14.2-25.el8.x86_64                                                            @@System
    Upgrade  rpm-build-libs-4.14.2-26.el8_1.x86_64                                               @BaseOS
    Upgraded rpm-build-libs-4.14.2-25.el8.x86_64                                                 @@System
    Upgrade  rpm-libs-4.14.2-26.el8_1.x86_64                                                     @BaseOS
    Upgraded rpm-libs-4.14.2-25.el8.x86_64                                                       @@System
    Upgrade  rpm-plugin-selinux-4.14.2-26.el8_1.x86_64                                           @BaseOS
    Upgraded rpm-plugin-selinux-4.14.2-25.el8.x86_64                                             @@System
    Upgrade  rpm-plugin-systemd-inhibit-4.14.2-26.el8_1.x86_64                                   @BaseOS
    Upgraded rpm-plugin-systemd-inhibit-4.14.2-25.el8.x86_64                                     @@System
    Upgrade  rpm-sign-4.14.2-26.el8_1.x86_64                                                     @BaseOS
    Upgraded rpm-sign-4.14.2-25.el8.x86_64                                                       @@System
    Upgrade  sssd-2.2.0-19.el8_1.1.x86_64                                                        @BaseOS
    Upgraded sssd-2.2.0-19.el8.x86_64                                                            @@System
    Upgrade  sssd-ad-2.2.0-19.el8_1.1.x86_64                                                     @BaseOS
    Upgraded sssd-ad-2.2.0-19.el8.x86_64                                                         @@System
    Upgrade  sssd-client-2.2.0-19.el8_1.1.x86_64                                                 @BaseOS
    Upgraded sssd-client-2.2.0-19.el8.x86_64                                                     @@System
    Upgrade  sssd-common-2.2.0-19.el8_1.1.x86_64                                                 @BaseOS
    Upgraded sssd-common-2.2.0-19.el8.x86_64                                                     @@System
    Upgrade  sssd-common-pac-2.2.0-19.el8_1.1.x86_64                                             @BaseOS
    Upgraded sssd-common-pac-2.2.0-19.el8.x86_64                                                 @@System
    Upgrade  sssd-ipa-2.2.0-19.el8_1.1.x86_64                                                    @BaseOS
    Upgraded sssd-ipa-2.2.0-19.el8.x86_64                                                        @@System
    Upgrade  sssd-kcm-2.2.0-19.el8_1.1.x86_64                                                    @BaseOS
    Upgraded sssd-kcm-2.2.0-19.el8.x86_64                                                        @@System
    Upgrade  sssd-krb5-2.2.0-19.el8_1.1.x86_64                                                   @BaseOS
    Upgraded sssd-krb5-2.2.0-19.el8.x86_64                                                       @@System
    Upgrade  sssd-krb5-common-2.2.0-19.el8_1.1.x86_64                                            @BaseOS
    Upgraded sssd-krb5-common-2.2.0-19.el8.x86_64                                                @@System
    Upgrade  sssd-ldap-2.2.0-19.el8_1.1.x86_64                                                   @BaseOS
    Upgraded sssd-ldap-2.2.0-19.el8.x86_64                                                       @@System
    Upgrade  sssd-nfs-idmap-2.2.0-19.el8_1.1.x86_64                                              @BaseOS
    Upgraded sssd-nfs-idmap-2.2.0-19.el8.x86_64                                                  @@System
    Upgrade  sssd-proxy-2.2.0-19.el8_1.1.x86_64                                                  @BaseOS
    Upgraded sssd-proxy-2.2.0-19.el8.x86_64                                                      @@System
    Upgrade  systemd-239-18.el8_1.5.x86_64                                                       @BaseOS
    Upgraded systemd-239-18.el8_1.4.x86_64                                                       @@System
    Upgrade  systemd-container-239-18.el8_1.5.x86_64                                             @BaseOS
    Upgraded systemd-container-239-18.el8_1.4.x86_64                                             @@System
    Upgrade  systemd-libs-239-18.el8_1.5.x86_64                                                  @BaseOS
    Upgraded systemd-libs-239-18.el8_1.4.x86_64                                                  @@System
    Upgrade  systemd-pam-239-18.el8_1.5.x86_64                                                   @BaseOS
    Upgraded systemd-pam-239-18.el8_1.4.x86_64                                                   @@System
    Upgrade  systemd-udev-239-18.el8_1.5.x86_64                                                  @BaseOS
    Upgraded systemd-udev-239-18.el8_1.4.x86_64                                                  @@System
    Upgrade  code-1.44.1-1586789444.el7.x86_64                                                   @code
    Upgraded code-1.44.0-1586345467.el7.x86_64                                                   @@System
puter:~:{12:18:33}
Attempting to boot with the new kernel results in the boot process hanging, and then the (non-quiet) boot output to the display periodically flashes on, then off, etc. before going completely dark.

I don't know if it's relevant, but I had installed the NVIDIA driver 390.132 into kernel-4.18.0-147.5.1.el8_1.x86_64, and that was working perfectly, using these instructions: https://linuxconfig.org/how-to-install- ... n-centos-8
I'm not sure I'm not saying this right, but I perhaps the video driver wasn't 'akmod'-ed into the new kernel? I removed/blacklisted the nouveau driver. I don't know how to determine whether that's the case or not. I also don't know how to view the failing boot log from the kernel-4.18.0-147.5.1.el8_1.x86_64 boot process.

Does any have any ideas as to how to diagnose and potentially fix this problem?

Thanks, mitch

User avatar
TrevorH
Forum Moderator
Posts: 29072
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by TrevorH » 2020/04/16 20:47:17

Yes, those instructions are flawed. While they will work, each and every time you install a new kernel you will need to repeat those. It builds for the running kernel only.

We usually recommend use of the kmod-nvidia packages from the ELRepo third party yum repository. These use the EL stable KABI to produce drivers that survive most kernel updates - they do usually need to be updated at point release times.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

mprater
Posts: 20
Joined: 2020/04/16 19:10:33

Re: Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by mprater » 2020/04/16 21:47:37

Thanks for confirming my suspicions Trevor.

I'm not quite sure how to go about fixing the broken kernel - I'm guessing I'll need to boot to single-user and install kmod-nvidia then. As you can tell, I'm not terribly savvy about such things, so if anyone has a suggested approach, I'm all ears.

Thanks, mitch

User avatar
TrevorH
Forum Moderator
Posts: 29072
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by TrevorH » 2020/04/16 22:00:14

You can just hit Ctrl-Alt-F2 to switch to terminal 2, login as root at the cli and repeat the install.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

mprater
Posts: 20
Joined: 2020/04/16 19:10:33

Re: Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by mprater » 2020/04/16 22:11:55

I'm assuming "hit Ctrl-Alt-F2" happens during the kernel-4.18.0-147.8.1.el8_1.x86_64 (broken) boot, and "the install" means the kmod-nvidia package.

User avatar
TrevorH
Forum Moderator
Posts: 29072
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by TrevorH » 2020/04/16 22:20:24

Yes, reboot into the broken kernel and when it hangs (which is when it's trying to invoke the GUI), switch to terminal 2, login as root, repeat the .run file install then reboot again.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

mprater
Posts: 20
Joined: 2020/04/16 19:10:33

Re: Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by mprater » 2020/04/16 22:32:11

Very good - thanks for clarifying.

I'd like to stop using the manually installed nvidia driver and switch to using the kmod-nvidia package instead. Once I've installed the nvidia driver manually (using the .run file), what's the process for "switching" from that to the kmod package? It feels like I'll first have to remove the manually installed driver before I can "activate"(?) the kmod-nvidia package.

User avatar
TrevorH
Forum Moderator
Posts: 29072
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by TrevorH » 2020/04/16 22:47:54

Yes, I believe you run the .run file again with -uninstall or --uninstall (it has a -help or --help, can't remember which). Run that to uninstall it. Now I believe you'll want to install the ELRepo elrepo-release package then yum install nvidia-detect which should tell you which kmod-nvidia package to install then yum install that. It should do everything else you need like blacklisting nouveau etc.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

mprater
Posts: 20
Joined: 2020/04/16 19:10:33

Re: Update kernel-4.18.0-147.8.1.el8_1.x86_64 won't boot

Post by mprater » 2020/04/16 22:50:40

Ah yes, that's right, you use the .run file to uninstall as well.

I think that covers all my questions. Thanks so much Trevor!

mitch

Post Reply

Return to “CentOS 8 - General Support”