Page 1 of 1

CentOS 8 and versionlock not behaving as expected

Posted: 2020/06/17 16:09:50
by MargoK
Just started playing around with CentOS 8 and I'm seeing some odd behavior using the versionlock plugin. Basically I'm building a docker container and I'm starting with centos:centos8.1.1911. I make sure all the repos I need are enabled, install the versionlock package and setup my versionlock.list file (basically following the same process I've been doing for CentOS 7). What I'm seeing is that a handful of packages have been downgraded from what I have in my versionlock.list file. What am I missing?

I'll use the binutils package for this example

This is what I have in the versionlock.list file (and yes this is the file specified in the versionlock.conf file)

Code: Select all

$ grep binutils /etc/dnf/plugins/versionlock.list 
binutils-2.30-58.el8_1.1.x86_64
This what is actually installed

Code: Select all

$ yum list installed binutils
Installed Packages
binutils.x86_64                                        2.30-58.el8.0.1                                        @System
This is what's available

Code: Select all

$ yum list available binutils
Last metadata expiration check: 0:08:46 ago on Fri 27 Mar 2020 12:46:24 PM UTC.
Available Packages
binutils.i686                                          2.30-58.el8                                             BaseOS
binutils.x86_64                                        2.30-58.el8_1.1                                         BaseOS
Now when I try and run yum update it tells me there's nothing to do (even though I have the _1.1 version specified in the versionlock.list file

Code: Select all

# yum update
Last metadata expiration check: 0:16:15 ago on Fri 27 Mar 2020 12:46:24 PM UTC.
Dependencies resolved.
Nothing to do.
Complete!
If I clear that entry in the versionlock.list file and run the update again it works

Code: Select all

# yum versionlock delete binutils
Last metadata expiration check: 0:20:26 ago on Fri 27 Mar 2020 12:46:24 PM UTC.
Deleting versionlock for: binutils-2.30-58.el8_1.1.x86_64
# yum update
Last metadata expiration check: 0:21:07 ago on Fri 27 Mar 2020 12:46:24 PM UTC.
Dependencies resolved.
=====================================================================================================================
 Package                   Architecture            Version                             Repository               Size
=====================================================================================================================
Upgrading:
 binutils                  x86_64                  2.30-58.el8_1.1                     BaseOS                  5.7 M

Transaction Summary
=====================================================================================================================
Upgrade  1 Package

Total download size: 5.7 M
Is this ok [y/N]: