Page 2 of 3

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/01/21 23:28:28
by advsp
But is there a chance that this is not related to the driver and the no boot is being caused by something else? If so, then why is the 8.1 driver not working even though I have installed it now? It seems to me that there is something else going on here or it would have worked once I install the up-to-date driver.

I saw some writings about centosplus. Is the only difference that it adds more drivers or are there other differences? I would rather avoid other possible complicating changes.

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/01/21 23:41:43
by toracat
The centosplus kernel has two main roles. One is to enable features that are disabled in the distro kernel. megaraid_sas is one such example. The other is to apply patches to fix known issues. Those patches may eventually go into the distro kernel but they have to come through the upstream (RHEL) kernel.

In your case, yes, there could be something else that is causing the problem with 8.1. You could revert the kernel to the version in 8.0 and revert the kmod to 8.0 as well and see if the system now boots. It's supposed to. If all is well, then update both the kernel and the kmod to ver 8.1 and test.

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/01/24 05:01:50
by advsp
Just to update:

I reverted the kernel and it still did not boot.

I had too much time wasted with it so instead of fooling with the CentOS+ stuff I blew the system away and did a reinstall but with v8.1 right from the beginning. It installed and boots fine.

I would love to know what happened with the upgrade form 8.0 to 8.1 to mess things up. Not an auspicious start with CentOS 8.

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/01/24 06:06:03
by KernelOops
I had that happen to me on two VM systems. After the 8.1 update, they would not boot normally but rescue mode worked fine.

In my case, something during the update broke /boot, more specifically, it was missing:

The file /boot/grub2/grubenv was there as a broken symlink.

To rescue these systems I had to:

Code: Select all

grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-install /dev/sda
I have no idea why grub was broken like that, maybe one of the upgraded or removed packages had some dependency or post-uninstall script that removes grub.

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/01/24 06:56:27
by toracat

Did you have any kmod package installed? Or is this issue not related to kmod?

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/01/24 08:40:22
by KernelOops
No I do not have kmod or anything extra installed, those are 4 systems, 2 acting as web servers and 2 acting as email servers.

Just normal things installed like apache and postfix.

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/02/13 22:06:54
by jgauthier
I have the exact same problem. OS and driver installation work just fine unless I first install CentOS 8.0 and upgrade to 8.1. Then I cannot reboot with the 8.1 kernel because the drive is not detected anymore. If I install 8.0 with the megaraid sas driver 8_0, upgrade to 8.1 and do

dnf install kmod-megaraid_sas-07.707.51.00-1.el8_1.elrepo.x86_64.rpm

The rpm installation finishes successfully but still no way to reboot with the 8.1 kernel. Is there any missing step? Do I have to install elrepo before to install the rpm? It's not easy to do tests because each time I try something and it doesn't work I have to reinstall 8.0 from scratch and upgrade to 8.1 to test something else since I cannot boot anymore.

If I reinstall 8.1 from scratch with the 8_1 megaraid driver then everything works fine. The problem is that we have a bunch of R610 servers that we need to upgrade to CentOS 8 but if we need to reinstall everything every time a new version is released that will be unbearable. All I need is a way to upgrade the driver AFTER an upgrade (not during installation) but so far it doesn't work. By the way I also tried to load the driver with the installer disk and reboot but same thing.

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/02/13 22:14:48
by TrevorH
If you are using the ELRepo kmods then you MUST install elrepo-release and have it enabled so that a yum update will install the matching kmod for the new kernel at the same time.

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/02/17 23:15:22
by jgauthier
Thank you very much for the reply! So, just to make sure (as I said every mistake leads to a complete reinstall so I would like to have a clear step by step), I should:

1- Install Centos 8.0 (and the raid driver otherwise the drive is not visible).

2-Do a dnf update

3-Install elrepo-release:

Download latest elrepo-release rpm from ... 6_64/RPMS/

Install elrepo-release rpm:

# rpm -Uvh elrepo-release*rpm

Install elrepo-release rpm package:

# dnf --enablerepo=elrepo-extras install elrepo-release

4-upgrade to Centos 8.1

5-install the 8.1 megaraid driver

dnf install kmod-megaraid_sas-07.707.51.00-1.el8_1.elrepo.x86_64.rpm

6-Redo a dnf update

Is there anything missing? Or anything I should not do?

Re: Cannot boot after CentOS 8.1 update

Posted: 2020/02/18 00:05:15
by TrevorH
If you install elrepo-release and leave the main elrepo repo enabled and then dnf update, it should already have updated kmod-megaraid_sas at the same time as the other updates. And once you install elrepo-release once, there's no need to install it again. If you leave elrepo enabled then you will pick up the latest update which is currently

Code: Select all

kmod-megaraid_sas.x86_64                          07.707.51.00-1.el8_1.elrepo                   elrepo

install CentOS 8.0
dnf install elrepo-release (it's already in the CentOS 'extras' repo which is enabled by default, no need to download anything or rpm anything)
dnf update