Page 1 of 1

where do I find the dependencies for perl-Expect

Posted: 2019/12/29 13:31:09
by erenouf
I have a fresh install of CentOS 8 and I'm trying to install the perl-Expect package, but it cannot resolve dependencies for perl IO::Tty and IO:Pty.

Code: Select all

# dnf install perl-Expect
Last metadata expiration check: 0:40:33 ago on Sun 29 Dec 2019 07:46:51 AM EST.
Error:
 Problem: conflicting requests
  - nothing provides perl(IO::Tty) needed by perl-Expect-1.35-10.el8.noarch
  - nothing provides perl(IO::Pty) >= 1.11 needed by perl-Expect-1.35-10.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
The output of getinfo.sh package can be seen at https://pastebin.com/S91ZBVYV

Where can I find those packages, or is there another repo I need to enable?

Re: where do I find the dependencies for perl-Expect

Posted: 2019/12/29 17:47:45
by toracat
Try enabling the PowerTools repo.

Re: where do I find the dependencies for perl-Expect

Posted: 2019/12/30 17:42:48
by erenouf
Perfect!

Code: Select all

dnf config-manager --set-enable PowerTools
dnf install perl-Expect
worked like a champ.

Thank you very much for the pointer!