Application package does not compile

Issues related to applications and software problems and general support
User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/05 10:24:19

jlehtone wrote:
2019/12/05 08:18:39
CentOS 7.0 is not a supported, secure environment.
You should either update to supported version (7.7) or disconnect your cluster from network.

BShT did not say: "compile on unsupported platform".
BShT did say: "edit TORQUE sources until it compiles on 8". (or 7.7)


Your cluster must have applications. Applications that have been "stable since 2012".
Applications that have been installed in CentOS 6. How do they run on CentOS 7?
How would they run on CentOS 8?

If you install some new application in CentOS 7, will it run in a CentOS 6 node?
Are your users happy with (versions of) applications from 2012?
The server is at CentOS release 6.10 (Final)
but CentOS 7 is installed on one of the nodes and it works in a cluster. And on this node stood CentOS 7 but the hard drive failed
Last edited by kerogaz on 2019/12/05 10:41:44, edited 2 times in total.

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/05 10:25:52

I was happy early. On Centos 7.0 i can not install NFS

Code: Select all

yum install nfs-utils 
------
gssproxy conflicts with selinux-policy-3.12.1-153.el7.noarch
yup update does not work

Code: Select all

initscripts-9.49.47-1.el7.x86_64 conflicts  with redhat-release < 7.5-0.11
-firewalld-0.6.3-2.el7_7.2.noarch  conflicts  with  selinux-policy < 3.13.1-118.el7
- openssh-7.4p1-21.el7.x86_64 conflicts  with selinux-policy < 3.13.1-92
-kernel-3.10.0-1062.7.1.el7.x86_64 conflicts  with selinux-policy-targeted < 3.13.1-201
 kernel-3.10.0-1062.7.1.el7.x86_6 conflicts  with kmod < 20-9
-
Error: kernel conflicts with selinux-policy-targeted-3.12.1-153.el7.noarch

Error: openssh conflicts with selinux-policy-3.12.1-153.el7.noarch
Error: firewalld conflicts with selinux-policy-3.12.1-153.el7.noarch
Error: kernel conflicts with kmod-14-9.el7.x86_64
Error: initscripts conflicts with centos-release-7-0.1406.el7.centos.2.3.x86_64

User avatar
jlehtone
Posts: 3019
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Application package does not compile

Post by jlehtone » 2019/12/05 10:41:22

Please show:

Code: Select all

yum list nfs-utils

User avatar
TrevorH
Forum Moderator
Posts: 29407
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Application package does not compile

Post by TrevorH » 2019/12/05 10:42:20

CentOS 7.0 is unsupported and has been since the release of 7.1 in 2015. It's more than 5 years old and there is no support for it at all, not even if you buy a RHEL EUS subscription and try to run RHEL 7.0. It's riddled with 5 years worth of security vulnerabilities, some very serious, and should not be used for anything excpet a demonstration of how to get hacked.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/05 10:45:25

jlehtone wrote:
2019/12/05 10:41:22
Please show:

Code: Select all

yum list nfs-utils

Code: Select all

 yum list nfs-utils

nfs-utils.x86_64                                                                  1:1.3.0-0.65.el7 

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/05 10:49:47

TrevorH wrote:
2019/12/05 10:42:20
CentOS 7.0 is unsupported and has been since the release of 7.1 in 2015. It's more than 5 years old and there is no support for it at all, not even if you buy a RHEL EUS subscription and try to run RHEL 7.0. It's riddled with 5 years worth of security vulnerabilities, some very serious, and should not be used for anything excpet a demonstration of how to get hacked.
And CentOS 6.10 will work ?

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/05 10:59:54

And more specifically: what Centos's release do I need to install so that when compiling my program there is no conflict with openssl-devel?

User avatar
jlehtone
Posts: 3019
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Application package does not compile

Post by jlehtone » 2019/12/05 11:17:36

kerogaz wrote:
2019/12/05 10:45:25

Code: Select all

 yum list nfs-utils
nfs-utils.x86_64   1:1.3.0-0.65.el7 
kerogaz wrote:
2019/12/05 10:25:52
yup update does not work

Code: Select all

Error: ... conflicts with ...
You have 7.0 packages installed. You are trying to install 7.7 packages.
Dependencies between packages make that difficult.
You should have installed the 7.7 directly.
kerogaz wrote:
2019/12/05 10:59:54
what do I need to install so that when compiling my program there is no conflict with openssl-devel?
Do you understand the issue behind the error? It seems that you don't.

openssl is an encryption tool for secure communication.
The old openssl is no longer secure. It cannot be used anywhere.

"Your program" tries to use what should not be used.

You try to solve that by getting the old openssl from somewhere. That is wrong.

You have to change your program, (or get a program that does the right thing).

User avatar
TrevorH
Forum Moderator
Posts: 29407
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Application package does not compile

Post by TrevorH » 2019/12/05 11:27:56

CentOS 6.10 is not really the right answer. It has less than 1 year left before it goes out of support completely. You should be aiming to migrate off it before then not move more onto it.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/05 11:37:38

TrevorH wrote:
2019/12/05 11:27:56
CentOS 6.10 is not really the right answer. It has less than 1 year left before it goes out of support completely. You should be aiming to migrate off it before then not move more onto it.
But some clusters still successfully operate at CentOS 5 and no one wants to redo them

Post Reply

Return to “CentOS 8 - General Support”