Page 5 of 8

Re: Application package does not compile

Posted: 2019/12/04 14:36:34
by kerogaz
Post by BShT » 2019/11/29 15:03:09

from http://docs.adaptivecomputing.com/torqu ... Torque.htm

2.2.1.A Supported Operating Systems

CentOS 6.x, 7.x
RHEL 6.x, 7.x
Scientific Linux 6.x, 7.x
SUSE Linux Enterprise Server 11, 12

Re: Application package does not compile

Posted: 2019/12/04 14:37:09
by jlehtone
kerogaz wrote:
2019/12/04 14:12:11
latest version torque 6.1.1.1 https://www.adaptivecomputing.com/products/torque/ also cannot be installed in CentOS 8. See my posts above
Do you understand why the installations (of your torque versions) fails in debian, el7 and el8?
kerogaz wrote:
2019/12/04 14:21:14
torque 4.2.4.1.tar.gz and torque 6.1.1.1.tar.gz (Adaptivecomputuing)
You have had 4.2.4.1. Everything else is "other than 4.2.4.1".
The 4.2.10 and 6.1.1 are both "other than 4.2.4.1", but only one you could trivially install.

Re: Application package does not compile

Posted: 2019/12/04 14:37:34
by TrevorH

Code: Select all

[root@centos8 ~]# dnf list \*torq\*
Last metadata expiration check: 0:27:08 ago on Wed Dec  4 13:50:29 2019.
Available Packages
torque.x86_64                                              4.2.10-17.el8                                        PowerTools
torque-devel.i686                                          4.2.10-17.el8                                        PowerTools
torque-devel.x86_64                                        4.2.10-17.el8                                        PowerTools
torque-libs.i686                                           4.2.10-17.el8                                        AppStream 
torque-libs.x86_64                                         4.2.10-17.el8                                        AppStream 

Re: Application package does not compile

Posted: 2019/12/04 14:42:59
by kerogaz
TrevorH wrote:
2019/12/04 14:37:34

Code: Select all

[root@centos8 ~]# dnf list \*torq\*
Last metadata expiration check: 0:27:08 ago on Wed Dec  4 13:50:29 2019.
Available Packages
torque.x86_64                                              4.2.10-17.el8                                        PowerTools
torque-devel.i686                                          4.2.10-17.el8                                        PowerTools
torque-devel.x86_64                                        4.2.10-17.el8                                        PowerTools
torque-libs.i686                                           4.2.10-17.el8                                        AppStream 
torque-libs.x86_64                                         4.2.10-17.el8                                        AppStream 
I have pbs_server 4.2.4.1 and pbs_mom ( node of the cluster) should be too 4.2.4.1 from the same tarball not 4.2.10-17

Re: Application package does not compile

Posted: 2019/12/04 14:45:11
by TrevorH
Good luck then.

Re: Application package does not compile

Posted: 2019/12/04 15:15:36
by jlehtone
I know that this requires some effort and your scrap-metal might not be worth it, but look at:
https://en.wikipedia.org/wiki/Slurm_Workload_Manager
https://slurm.schedmd.com/
https://slurm.schedmd.com/platforms.html

It has torque-wrappers too.


[edit:]
kerogaz wrote:
2019/12/04 12:17:04
for reliability I download now iso Centos 6.2
CentOS 6.2 should have been banished from this world July 9th, 2012 when CentOS 6.3 was released. Sounds like your cluster has been a security hazard its entire lifetime. :evil:

Re: Application package does not compile

Posted: 2019/12/04 16:55:16
by BShT
you have source, vi and gcc, make it compatible with Centos 8

Re: Application package does not compile

Posted: 2019/12/05 07:35:53
by kerogaz
Thanks. I compiled and installed torque 4.2.4.1 on Centos 7.0

Re: Application package does not compile

Posted: 2019/12/05 08:18:39
by jlehtone
CentOS 7.0 is not a supported, secure environment.
You should either update to supported version (7.7) or disconnect your cluster from network.

BShT did not say: "compile on unsupported platform".
BShT did say: "edit TORQUE sources until it compiles on 8". (or 7.7)


Your cluster must have applications. Applications that have been "stable since 2012".
Applications that have been installed in CentOS 6. How do they run on CentOS 7?
How would they run on CentOS 8?

If you install some new application in CentOS 7, will it run in a CentOS 6 node?
Are your users happy with (versions of) applications from 2012?

Re: Application package does not compile

Posted: 2019/12/05 10:21:17
by kerogaz
I was happy early. On Centos 7.0 i can not install NFS

Code: Select all

yum install nfs-utils 
------
gssproxy conflicts with selinux-policy-3.12.1-153.el7.noarch