Page 2 of 8

Re: Application package does not compile

Posted: 2019/11/29 07:49:02
by MartinR
Why are you trying to compile it? C7.7 has 4.2.10-10.el7 and C8.0 has 4.2.10-17.el8, both in epel. They should both play happily with 4.2.4.1 and it's a lot easier just to use yum to install the package than trying to build it.

Re: Application package does not compile

Posted: 2019/11/29 08:01:36
by kerogaz
Are you sure 4.2..10 will work? 4.2.4.1 is specific package of universite I remember it was incompatible even with 4.2.6.1. On the cluster on all nodes is sentos 6 and centos 7 with torque 4.2.4.1. Cluster is stable since 2012 and I would not want to break it with innovations And I started using 8 just because support 6 ends

Re: Application package does not compile

Posted: 2019/11/29 08:34:56
by MartinR
I'm not offering any guarantees, hence should. I had major problems moving a cluster from torque 2 to 4, but then you would expect that with two major changes. Unless you are doing something weird then a minor difference shouldn't pose a problem. Unfortunately, I don't have access to a cluster at the moment, only home PCs and they're all on C7.7 apart from the test VM on C8.0

Re: Application package does not compile

Posted: 2019/11/29 08:40:50
by kerogaz
I understood. At 7.7 I also have no problems. And on 8 openssl-devel does not work correctly and compat-openssl10-devel is not in the repositories

Re: Application package does not compile

Posted: 2019/11/29 09:37:59
by MartinR
Sorry for the noise. I've been checking out the distros and see that whilst C7.7 provides:
  • torque.x86_64
  • torque-client.x86_64
  • torque-libs.x86_64
  • torque-mom.x86_64
  • torque-scheduler.x86_64
  • torque-server.x86_64
it appears that C8 only provides the base torque package. Now I understand why you're attempting to build it!

Re: Application package does not compile

Posted: 2019/11/29 09:48:10
by kerogaz
Voila :)

Re: Application package does not compile

Posted: 2019/11/29 09:57:14
by kerogaz
"Tomas Mraz 2019-10-14 07:59:39 UTC
This is on purpose. We do not produce the compat-openssl10-devel package at all as nothing requires it to build in RHEL-8." :o

Re: Application package does not compile

Posted: 2019/11/29 13:03:09
by BShT
from http://docs.adaptivecomputing.com/torqu ... Torque.htm

2.2.1.A Supported Operating Systems

CentOS 6.x, 7.x
RHEL 6.x, 7.x
Scientific Linux 6.x, 7.x
SUSE Linux Enterprise Server 11, 12

Re: Application package does not compile

Posted: 2019/11/29 15:13:15
by kerogaz
The version torque 4.2.4.1 that I have is not related with Adaptivecomputing but developed at the University. The question is why it does not compile in Centos 8. Maybe other programs are also not compiled

Re: Application package does not compile

Posted: 2019/11/29 15:23:23
by BShT
because you need an old ssl package

you can:
Use CentOS 7
Wait for developer to update the code
Update the code yourself
Wait for someone to build openssl-compat-devel or build it yourself