Black screen after Login after installing NVIDIA drivers

Issues related to applications and software problems and general support
User avatar
warron.french
Posts: 510
Joined: 2014/03/27 20:21:58

Re: Black screen after Login after installing NVIDIA drivers

Post by warron.french » 2020/02/14 04:32:33

@nuhaio,
you have to blacklist the nouveau driver (the native video driver of both RHEL and CentOS).
There are different methods for accomplishing this, the one that I remember best, but may not be the best method to use is to inject the text string 'nouveau' into the file /etc/modprobe.d/blacklist.conf, you can do this with:

Code: Select all

echo 'nouveau' >> /etc/modprobe.d/blacklist.conf
I have a question for you though. Did you install the NVIDIA drivers via RPM or by using the blob file NVIDIA*.run?

The black screen occurs because you are successfully blacklisting the nouveau driver; however, the problem that still exists is that the video driver you want running is not loading at all; therefore you are left with no video driver in place at all.

Finally, to check if your NVIDIA driver is loaded you can simply execute a lsmod command and grep out the string 'nvidia' perhaps like this:

Code: Select all

lsmod | egrep -i  nvidia
Thanks,
War

robnunin
Posts: 3
Joined: 2015/01/13 21:18:17

Re: Black screen after Login after installing NVIDIA drivers

Post by robnunin » 2020/07/18 17:38:59

Confirmed also on my side.

Latest kernel CentOS 8.2 and driver 440.82
Removing rhgb from default kernel boot parameters solved.

Thanks

robnunin
Posts: 3
Joined: 2015/01/13 21:18:17

Re: Black screen after Login after installing NVIDIA drivers

Post by robnunin » 2020/07/18 17:40:54

Same here. Good solution !

Post Reply

Return to “CentOS 8 - General Support”