Installing ssmtp - still not found after installing EPEL?

Issues related to applications and software problems and general support
Post Reply
Posts: 1
Joined: 2019/10/30 14:58:59

Installing ssmtp - still not found after installing EPEL?

Post by dgorgan » 2019/10/30 15:15:30

I'm trying to install ssmtp to relay mail to Office 365, but I can't seem to install it. I've followed instructions to install EPEL to make ssmtp available, but I've seen no change after doing so.

To be honest, I'm having issues with sendmail and I'm trying to set up a relay to Office 365. I'm just looking for a simpler solution - if there's an alternative to ssmtp available to CentOS, I'd be happy to hear it.

User avatar
Forum Moderator
Posts: 28884
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installing ssmtp - still not found after installing EPEL?

Post by TrevorH » 2019/10/30 15:40:12

The ssmtp package is orphaned in EPEL as far as I know. That means it has no maintainer who will produce newer packages. The msmtp package isn't there either.

CentOS 8 is just a month old and many EPEL contributors won't even start to package for EPEL 8 until CentOS 8 comes out as they don't have RHEL licenses. If a package is orphaned then there is no-one to build it and care for it so it doesn't get added.

For now I would use postfix since that comes out of the box configured to relay mail from localhost to the intended destination. You can easily change that to deliver it to a smarthost too.

EPEL packages are managed via You can search there for existing bug reports and raise new ones if there are none currently. There are Fedora pages about how to become an EPEL maintainer should you wish to help build and maintain things in the future.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 8 - General Support”