GPG check FAILED after groupinstall Development Tools

Issues related to applications and software problems and general support
Post Reply
Posts: 1
Joined: 2019/10/28 13:17:21

GPG check FAILED after groupinstall Development Tools

Post by arojnuckarin » 2019/10/28 13:54:05


I got a centos:latest container from docker hub, run yum -y groupinstall "Development Tools", which completes successfully, then I run yum -y install openssl-devel, I got "GPG check FAILED" message. I tried a few other packages and they all fail with the same "GPG check FAILED" message. If I run yum install before yum groupinstall, it works OK. I also tried "dnf" instead of "yum" and it seems to run into the same problem.
(3.49 KiB) Downloaded 9 times
It seems this is a recent problem. The install commands were run successfully on Oct 10 (the last time I run my build pipeline). I have workaround for the time being, but this order dependent behavior is definitely weird.

Thanks in advance,

User avatar
Forum Moderator
Posts: 29120
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: GPG check FAILED after groupinstall Development Tools

Post by TrevorH » 2019/10/28 15:23:57

Both work for me.

What is the output from rpm -qa gpg\* after running the group install and accepting the key but before trying the next install.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 8 - General Support”