How to install apcupsd on Centos 8?

Issues related to applications and software problems and general support
oSAlj
Posts: 12
Joined: 2019/10/26 12:32:19

How to install apcupsd on Centos 8?

Post by oSAlj » 2019/10/26 12:40:29

Hi to all!

How to install UPS monitoring software (apcupsd) on Centos 8? yum install apcupsd does not find the package. I have the epel-release package installed.

Thanks for any help

User avatar
TrevorH
Forum Moderator
Posts: 29985
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: How to install apcupsd on Centos 8?

Post by TrevorH » 2019/10/26 13:55:49

Packages in EPEL are tracked via bugzilla.redhat.com in the Fedora EPEL section. You need to check there and see if there is an existing bz requesting apcupsd for el8 and if not present then create one.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

oSAlj
Posts: 12
Joined: 2019/10/26 12:32:19

Re: How to install apcupsd on Centos 8?

Post by oSAlj » 2019/10/27 14:29:09

When can we expect more packages in CentOS 8?
There are currently no acpupsd, hddtemp, uptimed and several other packages.

User avatar
TrevorH
Forum Moderator
Posts: 29985
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: How to install apcupsd on Centos 8?

Post by TrevorH » 2019/10/27 14:49:51

Those have never been in CentOS or RHEL. They all come from EPEL. The correct way to request packages from EPEL is via a bz on bugzilla.redhat.com in the Fedora EPEL section. Search first and see if there is already an open request and if not, raise one.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
KernelOops
Posts: 395
Joined: 2013/12/18 15:04:03
Location: xfs file system

Re: How to install apcupsd on Centos 8?

Post by KernelOops » 2019/10/28 09:58:16

I think the project apcupsd was abandoned a while ago. I think most people these days have moved on to "nut" (https://networkupstools.org/). Maybe you'd like to give it a try?
--
I love my computer - all my friends live there.
--

nouvo09
Posts: 183
Joined: 2009/09/19 19:21:36
Location: Paris, France

Re: How to install apcupsd on Centos 8?

Post by nouvo09 » 2019/10/28 10:53:09

Code: Select all

dnf search apcupsd
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:16:41 le lun. 28 oct. 2019 11:34:37 CET.
============================== Nom correspond exactement à : apcupsd ===============================
apcupsd.x86_64 : APC UPS Power Control Daemon
=============================== Nom & Résumé correspond à : apcupsd ================================
apcupsd-cgi.x86_64 : Web interface for apcupsd
apcupsd-gui.x86_64 : GUI interface for apcupsd

Code: Select all

 # uname -r
5.3.6-100.fc29.x86_64

I don't think this project is abandonned at all.
Member of centos-FR forum

oSAlj
Posts: 12
Joined: 2019/10/26 12:32:19

Re: How to install apcupsd on Centos 8?

Post by oSAlj » 2019/10/28 16:20:23

I try to install NUT but I have problem with pygtk2-libglade

Code: Select all

[root@server01 ~]# dnf install nut
Last metadata expiration check: 0:40:41 ago on Mon 28 Oct 2019 15:35:34 GMT.
Error:
 Problem: package nut-2.7.4-24.el8.x86_64 requires libupsclient.so.4()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides pygtk2-libglade needed by nut-client-2.7.4-24.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@server01 ~]# yum provides */pygtk2-libglade
Last metadata expiration check: 0:41:14 ago on Mon 28 Oct 2019 15:35:34 GMT.
Error: No Matches found
[root@server01 ~]# yum search pygtk2-libglade
Last metadata expiration check: 0:41:29 ago on Mon 28 Oct 2019 15:35:34 GMT.
No matches found.
[root@server01 ~]#
On the bugzilla.redhat.com I find this
https://bugzilla.redhat.com/show_bug.cgi?id=1757210

_________________
EDIT:
_________________

I installed CentOS 8 on my HP Microserver N36L with 4GB RAM. This is the server for Nextcloud, DLNA, http. I wonder if it would be better if I installed the system again, but in version 7. I don't know what will be better for me.

nouvo09
Posts: 183
Joined: 2009/09/19 19:21:36
Location: Paris, France

Re: How to install apcupsd on Centos 8?

Post by nouvo09 » 2019/10/28 16:45:26

If it was me, I'll search into fedora 25 repos which works with a 4.13 kernel, then if available, download the package and then try the installation
with a
rpm -ivh apcupsd.x86_64.......rpm --test

and if not error is reported then install it for good (i-e without --test)

[edit]
you can find package apcupsd-3.14.14-2.fc25.x86_64.rpm

at https://dl.fedoraproject.org/pub/archiv ... ackages/a/
[/edit]
Last edited by nouvo09 on 2019/10/28 17:01:12, edited 1 time in total.
Member of centos-FR forum

User avatar
TrevorH
Forum Moderator
Posts: 29985
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: How to install apcupsd on Centos 8?

Post by TrevorH » 2019/10/28 16:51:50

dnf --enablerepo=epel-testing install nut
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

oSAlj
Posts: 12
Joined: 2019/10/26 12:32:19

Re: How to install apcupsd on Centos 8?

Post by oSAlj » 2019/10/28 18:30:48

Thanks TrevorH for NUT :D

No I have problem when nut-server starting

Code: Select all

Can't connect to UPS [backups900] (usbhid-ups-backups900): No such file or directory
my ups.conf

Code: Select all

[backups900]
driver=usbhid-ups
port=auto
vendorid = 051D
productid = 0002
product = "Back-UPS RS 900G FW:879.L4 .I USB FW:L4"
serial = 3B1234X15875
vendor = "American Power Conversion"
bus = 005
If it changes the name ups from backups900 to myups
error at startup is this:

Code: Select all

Can't connect to UPS [backups900] (usbhid-ups-myups): No such file or directory

Post Reply

Return to “CentOS 8 - General Support”