CentOS 8 Pane is dead VMware Workstation 15.5

Issues related to applications and software problems and general support
Post Reply
araczek
Posts: 3
Joined: 2019/10/09 13:49:42

CentOS 8 Pane is dead VMware Workstation 15.5

Post by araczek » 2019/10/09 14:10:13

Hello,

I am using VMware Workstation 15.5 and trying to install CentOS 8. When I boot and it starts the installer it gives me a message on the
bottom "Pane is dead". I tried to set "install operating system later", picked CentOS 7, selected ISO as the CD ROM device and attempted the install.
Unfortunately VMware does not pick up the boot device as ISO and goes right to DHCP boot. So I tried a CentOS 7 ISO, same thing. I just upgraded VMware Workstation from 15.0 to 15.5.

Any other detailed workaround I can try? Next I will burn a dvd.

...AR

User avatar
TrevorH
Forum Moderator
Posts: 28095
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 8 Pane is dead VMware Workstation 15.5

Post by TrevorH » 2019/10/09 14:16:26

Did you check the sha256sum of your downloaded file against the list in the CentOS 8 Release Notes? Have you given your VM adequate RAM - it needs at least 2GB even for a text install. Do not use the VMWare "Easy Install" option.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

araczek
Posts: 3
Joined: 2019/10/09 13:49:42

Re: CentOS 8 Pane is dead VMware Workstation 15.5

Post by araczek » 2019/10/09 14:48:58

Thank you for reply

I did not check the checksum but downloaded from 3 different mirrors. Also I set the VM to 8Gb ram.

...ar

User avatar
Errosion
Posts: 38
Joined: 2014/12/03 19:58:02

Re: CentOS 8 Pane is dead VMware Workstation 15.5

Post by Errosion » 2019/10/09 17:43:27

I mentioned this fix in another thread.

If you attempt to install C8 on VMWare 15.5, VMWare Player attempts to do some auto install stuff that does not seem to work.

To work around that, when building the VM, don't check the box to "Start VM after creation". Go to the hardware settings on the VM and remove the "autostart.inf" (I think it is called) line, and I think shows up as a CD/DVD drive. That is the "easy install" the above poster refers to.

Once that line is removed, then start the VM and you should get to the standard "install, verify and install, etc" screen and it work from there.

At least, that is what I did and got it working. You are essentially bypassing the VMware kickstart that it tries to do with certain linux distros.

jonny2019
Posts: 1
Joined: 2019/10/10 07:12:02

Re: CentOS 8 Pane is dead VMware Workstation 15.5

Post by jonny2019 » 2019/10/10 07:27:04

I just try to add a bit more details to what #Errosion has mentioned

when using VMware workstation 15.x, it will not recognise Centos8.
It will say something like "CentOS version 5 or earlier 64 bit detected". just ignore it, press next, fill in some details (which are not going to be used anyway) and click next.

there will be a point where you can uncheck "power on vm after creation".
Do not tick that box.
click "finish". VM will be created. (but not power up).

Selected the newly created VM.
Go and edit VM settings.
Inside there, under hardware, you will see CD/DVD -> using file autoinst.iso
Remove it. start your VM again.

And you are good. the rest will be smooth like silk.

Thanks #Errosion for helping me too!

User avatar
Errosion
Posts: 38
Joined: 2014/12/03 19:58:02

Re: CentOS 8 Pane is dead VMware Workstation 15.5

Post by Errosion » 2019/10/10 16:16:26

Thanks for the additional clarification on that, jonny2019.

I wasn't able to look at the exact specifics in VMware Player when writing that up, so was basing those notes entirely on memory...and these days, that is suspect at best!

Glad I could help!

kroopani
Posts: 4
Joined: 2017/11/02 18:18:12

Re: CentOS 8 Pane is dead VMware Workstation 15.5

Post by kroopani » 2019/11/10 23:56:20

@ jonny2019

Thanks jonny2019 it worked

killingthemonkey
Posts: 4
Joined: 2016/08/17 03:16:48

Re: CentOS 8 Pane is dead VMware Workstation 15.5

Post by killingthemonkey » 2020/02/13 16:48:32

jonnyy2019 & Errosion,,,
This solution is still working.

Thank you, both

Post Reply

Return to “CentOS 8 - General Support”