glibc-2.28-180 or glibc-2.28-181

Issues related to applications and software problems and general support
Post Reply
cmardini
Posts: 2
Joined: 2022/01/12 19:01:16

glibc-2.28-180 or glibc-2.28-181

Post by cmardini » 2022/01/12 19:07:02

I encountered this today around 18:30 UTC don't know if others have seen the same or if it is a mirror-local problem:

Code: Select all

# docker pull quay.io/centos/centos:stream8
Trying to pull repository quay.io/centos/centos ... 
stream8: Pulling from quay.io/centos/centos
Digest: sha256:562977664897442ac9e66181786df2c460e9148ca8bd59cbdc499654c74d567f
Status: Image is up to date for quay.io/centos/centos:stream8

# docker run --rm -it quay.io/centos/centos:stream8

[root@9f7370dc676c /]# dnf distro-sync
CentOS Stream 8 - AppStream                                                                                                                                       5.6 MB/s |  19 MB     00:03    
CentOS Stream 8 - BaseOS                                                                                                                                           10 MB/s |  18 MB     00:01    
CentOS Stream 8 - Extras                                                                                                                                           44 kB/s |  16 kB     00:00    
Last metadata expiration check: 0:00:01 ago on Wed Jan 12 19:05:01 2022.
Error: 
 Problem 1: package glibc-gconv-extra-2.28-180.el8.x86_64 requires glibc(x86-64) = 2.28-180.el8, but none of the providers can be installed
  - cannot install both glibc-2.28-181.el8.x86_64 and glibc-2.28-180.el8.x86_64
  - cannot install the best update candidate for package glibc-gconv-extra-2.28-167.el8.x86_64
  - cannot install the best update candidate for package glibc-2.28-167.el8.x86_64
 Problem 2: problem with installed package glibc-gconv-extra-2.28-167.el8.x86_64
  - package glibc-gconv-extra-2.28-167.el8.x86_64 requires glibc-common = 2.28-167.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-170.el8.x86_64 requires glibc-common = 2.28-170.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-174.el8.x86_64 requires glibc-common = 2.28-174.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-180.el8.x86_64 requires glibc-common = 2.28-180.el8, but none of the providers can be installed
  - cannot install both glibc-common-2.28-181.el8.x86_64 and glibc-common-2.28-167.el8.x86_64
  - cannot install both glibc-common-2.28-181.el8.x86_64 and glibc-common-2.28-170.el8.x86_64
  - cannot install both glibc-common-2.28-181.el8.x86_64 and glibc-common-2.28-174.el8.x86_64
  - cannot install both glibc-common-2.28-181.el8.x86_64 and glibc-common-2.28-180.el8.x86_64
  - cannot install the best update candidate for package glibc-common-2.28-167.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

User avatar
TrevorH
Site Admin
Posts: 31483
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: glibc-2.28-180 or glibc-2.28-181

Post by TrevorH » 2022/01/12 22:00:06

Try waiting a while and then try again. It's not that long since these updates were pushed to the mirrors and apparently el8 now uses multiple mirrors for different packages so it's possible that you pull one glibc from one mirror and a different version from another. A yum clean all may also help.
CentOS 8 died a premature death at the end of 2021 - migrate to Rocky/Alma/OEL/Springdale ASAP.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are dead, do not use them.
Use the FAQ Luke

cmardini
Posts: 2
Joined: 2022/01/12 19:01:16

Re: glibc-2.28-180 or glibc-2.28-181

Post by cmardini » 2022/01/13 13:09:06

Thanks. Seems to be rolled out this morning. I was able to distro-sync successfully.

Post Reply

Return to “8 /8-Stream / 9-Stream - General Support”