Installing MATE from source

Issues related to applications and software problems and general support
User avatar
TrevorH
Forum Moderator
Posts: 30881
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installing MATE from source

Post by TrevorH » 2021/06/22 08:34:52

patch unexpectedly ends in middle of line
Your patch file is corrupt.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

aussie
Posts: 101
Joined: 2018/06/30 12:21:31

Re: Installing MATE from source

Post by aussie » 2021/06/30 06:56:25

Since the mate-settings-daemon patch is corrupt I compiled with an empty patch. But I get the following error when I try to install.

Code: Select all

[root@192-168-1-100 x86_64]# yum install mate-settings-daemon-1.22.0-1.el8.x86_64.rpm
Last metadata expiration check: 0:43:50 ago on Wed 30 Jun 2021 01:50:37 PM AWST.
Error: 
 Problem: conflicting requests
  - nothing provides mate-control-center-filesystem needed by mate-settings-daemon-1.22.0-1.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@192-168-1-100 x86_64]# 
But mate-control-center is dependent on the mate-setting daemon.

Code: Select all

mate-control-center-1.22.0-1.fc30.src.rpm
error: Failed build dependencies:
	mate-settings-daemon-devel is needed by mate-control-center-1.22.0-1.el8.x86_64

mate-utils-1.22.0-1.fc30.src.rpm
error: Failed build dependencies:
	mate-panel-devel is needed by mate-utils-1.22.0-1.el8.x86_64

mate-media-1.22.1-1.fc30.src.rpm
error: Failed build dependencies:
	mate-panel-devel is needed by mate-media-1.22.1-1.el8.x86_64

mate-applets-1.22.0-1.fc30.src.rpm
error: Failed build dependencies:
	mate-panel-devel is needed by mate-applets-1.22.0-1.el8.x86_64
	mate-settings-daemon-devel is needed by mate-applets-1.22.0-1.el8.x86_64

mate-applet-softupd-0.4.7-3.fc30.src.rpm
error: Failed build dependencies:
	dnfdragora-gui is needed by mate-applet-softupd-0.4.7-3.el8.x86_64
	mate-panel-devel >= 1.3.0 is needed by mate-applet-softupd-0.4.7-3.el8.x86_64
It seems I have a catch 22. Does anybody know how to resolve this?

Aussie

aussie
Posts: 101
Joined: 2018/06/30 12:21:31

Re: Installing MATE from source

Post by aussie » 2021/07/06 06:26:53

I installed the fc30 versions of mate-settings-daemon and mate-control-center and was able to successfully compile mate-control-center. So that problem solved.

I'm trying to resolve dependencies for caja and can't find some source rpms.

Code: Select all

[root@192-168-1-100 MATE-fc30-src-depend]# rpmbuild --rebuild caja-extensions-1.22.0-1.fc30.src.rpm
Installing caja-extensions-1.22.0-1.fc30.src.rpm
warning: caja-extensions-1.22.0-1.fc30.src.rpm: Header V3 RSA/SHA256 Signature, key ID cfc659b9: NOKEY
error: Failed build dependencies:
	caja-devel is needed by caja-extensions-1.22.0-1.el8.x86_64
	gajim is needed by caja-extensions-1.22.0-1.el8.x86_64
[root@192-168-1-100 MATE-fc30-src-depend]# 

[root@192-168-1-100 noarch]# yum install gajim-1.1.2-4.el8.noarch.rpm
Last metadata expiration check: 1:00:05 ago on Tue 06 Jul 2021 11:09:20 AM AWST.
Error: 
 Problem: conflicting requests
  - nothing provides python3.6dist(cssutils) >= 1.0.2 needed by gajim-1.1.2-4.el8.noarch
  - nothing provides python3.6dist(nbxmpp) >= 0.6.9 needed by gajim-1.1.2-4.el8.noarch
  - nothing provides python3.6dist(nbxmpp) < 0.7.0 needed by gajim-1.1.2-4.el8.noarch
  - nothing provides python3.6dist(precis-i18n) >= 1.0.0 needed by gajim-1.1.2-4.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I'm looking for the source packages here:
https://dl.fedoraproject.org/pub/archiv ... /Packages/
I couldn't find anything for: cssutils, nbxmpp or precis-i18n. There isn't anything under python3.6dist....

How do I find these dependencies?

Aussie

Post Reply

Return to “CentOS 8 - General Support”